13.0.0-rc4 has been tagged

Hi,

I've tagged 13.0.0-rc4. Please test and upload binaries. If all goes well, we
will release 13.0.0-final in ~1 week.

-Tom

Found on second pass of testing.13.0.0-rc4.log.

232300:make[2]: *** [tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/build.make:108: tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/check-expression.cpp.o] Error 137

grep -n ' Error' testing.13.0.0-rc4.log
153010:make[3]: *** [CMakeFiles/check-all.dir/build.make:77: CMakeFiles/check-all] Error 1
153012:make[2]: *** [CMakeFiles/Makefile2:31045: CMakeFiles/check-all.dir/all] Error 2
153013:make[1]: *** [CMakeFiles/Makefile2:31052: CMakeFiles/check-all.dir/rule] Error 2
153015:make: *** [Makefile:283: check-all] Error 2
232300:make[2]: *** [tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/build.make:108: tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/check-expression.cpp.o] Error 137
232834:make[1]: *** [CMakeFiles/Makefile2:238587: tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/all] Error 2
233271:make: *** [Makefile:171: all] Error 2

grep -n 'Expectedly Failed' testing.13.0.0-rc4.log
153008: Expectedly Failed: 342

Neil Nelson

For 13.0.0 rc4, I have built and tested on both FreeBSD 12 and 13. No
additional patches were needed, as they were merged.

For the 32-builds I used -no-flang, as flang is currently not 32-bit
clean, and I do not expect it will ever be. (Also, these builds consume
a huge amount of RAM, making native compilation likely impossible.)

Main results on amd64-freebsd12:

  Skipped : 3 (rc3: 3)
  Unsupported : 6353 (rc3: 6353)
  Passed : 91830 (rc3: 91823)
  Expectedly Failed : 320 (rc3: 320)
  Failed : 300 (rc3: 300)
  Unexpectedly Passed: 2 (rc3: 2)

Test suite results on amd64-freebsd12:

  Passed: 2419 (rc3: 2419)
  Failed: 3 (rc3: 3)

Main results on amd64-freebsd13:

  Skipped : 3 (rc3: 3)
  Unsupported : 6352 (rc3: 6352)
  Passed : 91794 (rc3: 91789)
  Expectedly Failed : 320 (rc3: 320)
  Failed : 337 (rc3: 338)
  Unexpectedly Passed: 2 (rc3: 2)

Test suite results on amd64-freebsd13:

  Passed: 2419 (rc3: 2419)
  Failed: 3 (rc3: 3)

Main results on i386-freebsd12:

  Skipped : 3 (rc3: 3)
  Unsupported : 4738 (rc3: 4738)
  Passed : 87555 (rc3: 87552)
  Passed With Retry : 1 (rc3: 0)
  Expectedly Failed : 295 (rc3: 295)
  Failed : 198 (rc3: 198)
  Unexpectedly Passed: 1 (rc3: 1)

Main results on i386-freebsd13:

  Skipped : 3 (rc3: 3)
  Unsupported : 4738 (rc3: 4738)
  Passed : 87553 (rc3: 87550)
  Passed With Retry : 1 (rc3: 0)
  Expectedly Failed : 295 (rc3: 295)
  Failed : 200 (rc3: 200)
  Unexpectedly Passed: 1 (rc3: 1)

Uploaded:
SHA256 (clang+llvm-13.0.0-rc4-amd64-unknown-freebsd12.tar.xz) = 08f7a008243e69988edc5f9961f01b05d564b0173161d79749e58f88ba51f777
SHA256 (clang+llvm-13.0.0-rc4-amd64-unknown-freebsd13.tar.xz) = fcf85ebe864f45f414955c3b47685004dfc93bc5720ea0dd68b814df35549e8a
SHA256 (clang+llvm-13.0.0-rc4-i386-unknown-freebsd12.tar.xz) = f7bcaa7258e214ed2d3b65d975ccf6393c8455ac84873a4621b050ba3da41108
SHA256 (clang+llvm-13.0.0-rc4-i386-unknown-freebsd13.tar.xz) = 30f3f90ea80068d74f84e17134603b0d4b325d49e46be350800be78cee3e61a4

-Dimitry

No regressions here. I've seen some random compiler-rt test fluke once
but not on the second run. Let's release!

Hi Neil,

Thank you for helping with the release, that's much appreciated!

Found on second pass of testing.13.0.0-rc4.log.

232300:make[2]: *** [tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/build.make:108: tools/flang/lib/Evaluate/CMakeFiles/obj.FortranEvaluate.dir/check-expression.cpp.o] Error 137

This is out-of-memory error, right? That's most likely due to Flang's rather "unusual" memory requirements. AFAIK, there are no easy ways around it ATM. You could make sure not to use ld.bfd and experiment with LLVM_PARALLEL_LINK_JOBS. I suspect that you have already tried that. Unfortunately, I don't have any better suggestions.

-Andrzej

Indeed, for builds on 32-bit systems I used -no-flang, but on others, I limited the number of jobs with test-release.sh's -j option, and added additional RAM and swap to the VMs I was building on.

Specifically, I used -j 3 in combination with ~10G RAM, and 10G swap. That seemed to sufficient.

-Dimitry

macOS builds are up:
67290d48eaefc7ef967920036f9c6138718a48d3bd27fed9291438b7a88ae5bd

No regressions from rc3 - but without lldb.

-- Tobias

Windows is ready:

$ sha256sum LLVM-13.0.0-rc4*.exe
00fdd3bcfb1b853913173615a952ad8620ad3fffdd9073c6847f507dcef0c7e1
LLVM-13.0.0-rc4-win32.exe
2db961b768c4b6d07ebf24edd7bb79903057ca101557242af8f8afa2cb39e8bf
LLVM-13.0.0-rc4-win64.exe

build_llvm_1300-rc4.bat|attachment (5.04 KB)

Hi,

Uploaded armv7 & aarch64 linux, as well as aarch64 windows:
0065ffc133ea9ec3c51e1e3e16962451ac05d5e7682a6c01d15390828fe35df7 clang+llvm-13.0.0-rc4-aarch64-linux-gnu.tar.xz
366316f13b4f1cdf3bf6d5fdc9dd0720b914bba85e135c75d709f7c16cad35a0 clang+llvm-13.0.0-rc4-armv7a-linux-gnueabihf.tar.xz

386427d6d15b8acf3130ecfaa80dfbec3caaf71273e106e11bb5ba998321cf46 LLVM-13.0.0-rc4-woa64.zip

No new issues to report.

Cheers,
Diana

Were you able to confirm if the problems at building llvm on MacOS are
a misconfiguration in your machine or a regression?

ardi

Hi Tom,

Binaries for PowerPC 8 uploaded; sha1sum of each:
4d43daa8ce624a0a3cbaec7a2f0bb988b2f7a8df clang+llvm-13.0.0-rc4-powerpc64le-linux-ubuntu-18.04.tar.xz

76910db5b5bc8bf1fe8127a51ae4b02de799d243 clang+llvm-13.0.0-rc4-powerpc64le-linux-rhel-7.9.tar.xz

Thanks,
Albion

Hello Tom,

I’ve also uploaded 13.0.0 final binaries. SHA1:
44010f4632c6639585505c277fbd9a72700ba952 clang+llvm-13.0.0-powerpc64le-linux-rhel-7.9.tar.xz
f248d0097d0403db6106cb4942b59b309f0cf502 clang+llvm-13.0.0-powerpc64le-linux-ubuntu-18.04.tar.xz

Thanks,
Albion

Same here,

-final for macOS uploaded with sha
d051234eca1db1f5e4bc08c64937c879c7098900f7a0370f3ceb7544816a8b09

Still no lldb in this one.

-- Tobias

13.0.0-final for Windows:

$ sha256sum LLVM-13.0.0-win*.exe
0fb33b3c5b8ff78337fb0a8b54aa2f81a309d1fed57887195a29fa0f683444b8
LLVM-13.0.0-win32.exe
f81f08a8bd9d787ec0505a7475cdff9653516cbbc5804e973f8749a2139fa1cb
LLVM-13.0.0-win64.exe

build_llvm_1300-final.bat|attachment (5.04 KB)

We are looking good on Debian & Ubuntu
S

Uploaded final aarch64 & armv7:
968d65d2593850ee9b37fcda074fb7641529bd45d2f976af6c8197de3c22612f clang+llvm-13.0.0-aarch64-linux-gnu.tar.xz
e17aacd843cc7c3c3c27a0d2293af8b3e9ad76408f7c178a92a182f18e7734e5 clang+llvm-13.0.0-armv7a-linux-gnueabihf.tar.xz

Also windows on arm:
06cca441f010c35c9237e4fb51250928058295e64d20c6a6bb164d523dfe954d LLVM-13.0.0-woa64.zip

Sorry about the delay.