14.0.4-final has been tagged

Hi,

I’ve tagged 14.0.4, testers please upload binaries and report results.

Thanks,
Tom

macOS binaries are up with SHA: f6d9801b0bd78479229d21e2d5650c5a61f9ab1b6f80bad0dccf4b7a7eb30abf

Test failures are the same as with 14.0.3:

FAIL: Clang :: Driver/darwin-ld-lto.c (8205 of 96947)
FAIL: Flang :: Runtime/no-cpp-dep.c (33370 of 96947)
FAIL: LLVM :: ExecutionEngine/JITLink/X86/MachO_x86-64_self_relocation_exec.test (56535 of 96947)
FAIL: ORC-x86_64-darwin :: TestCases/Darwin/x86-64/trivial-cxa-atexit.S (82496 of 96947)
FAIL: ORC-x86_64-darwin :: TestCases/Darwin/x86-64/trivial-tlv.S (82497 of 96947)
FAIL: ORC-x86_64-darwin :: TestCases/Darwin/x86-64/trivial-static-initializer.S (82498 of 96947)
FAIL: ORC-x86_64-darwin :: TestCases/Darwin/x86-64/trivial-objc-methods.S (82499 of 96947)
FAIL: ORC-x86_64-darwin :: TestCases/Darwin/x86-64/trivial-swift-types-section.S (82509 of 96947)
FAIL: flang-OldUnit :: Evaluate/folding.test (85832 of 96947)
FAIL: libomp :: ompt/loadtool/tool_available_search/tool_available_search.c (94092 of 96947)
FAIL: libomp :: tasking/hidden_helper_task/gtid.cpp (94192 of 96947)
FAIL: libomp :: worksharing/for/kmp_sch_simd_guided.c (94241 of 96947)

Thanks!

Windows is ready. sha256sums:

dfba488afb0f96f1d08034184517e2d444970998a3f702656eb96d2e814f0013 LLVM-14.0.4-win32.exe
af4d442e33c57fc284c12ff187e92e52a53fd3694e8673fcd61b5d4582c1e8b9 LLVM-14.0.4-win64.exe

Built with
build_llvm_1404.bat.txt (5.1 KB)

The PowerPC (AIX 7.2) binaries for 14.0.4 have been uploaded.
Once again, compiler-rt was built as a runtime (and not as a project). No regressions were found.

9ce1656d28826fac4631c1bd519bdce47e62cabb  clang+llvm-14.0.4-powerpc64-ibm-aix-7.2.tar.xz

Armv7 and AArch64 ready:

0c960d50c83360d81e698120f131cf004676cbe5ac6db6fbe67a0950f3cde2d1  clang+llvm-14.0.4-aarch64-linux-gnu.tar.xz
09bb79557235aee16badc4e3db86a121b0b3c7af226e093c908a1c66c5a0c4c4  clang+llvm-14.0.4-armv7a-linux-gnueabihf.tar.xz
401a84658cfd92aa1e4fed422d282727143b774a26837181ec26dfab6de19323  LLVM-14.0.4-woa64.zip

No regressions.

For 14.0.4 final, I have built and tested on both FreeBSD 12 and 13. No additional patches were needed.

Main results on amd64-freebsd12:

  Skipped            :     4 (14.0.3:     4)
  Unsupported        :  6768 (14.0.3:  6772)
  Passed             : 97032 (14.0.3: 97021)
  Expectedly Failed  :   314 (14.0.3:   314)
  Timed Out          :     5 (14.0.3:     6)
  Failed             :   170 (14.0.3:   170)
  Unexpectedly Passed:     2 (14.0.3:     2)

Test suite results on amd64-freebsd12:

  Passed: 2420 (14.0.3: 2420)
  Failed:    3 (14.0.3:    3)

Main results on amd64-freebsd13:

  Skipped            :     4 (14.0.3:     4)
  Unsupported        :  6768 (14.0.3:  6772)
  Passed             : 96994 (14.0.3: 96985)
  Expectedly Failed  :   314 (14.0.3:   314)
  Timed Out          :     4 (14.0.3:     4)
  Failed             :   209 (14.0.3:   208)
  Unexpectedly Passed:     2 (14.0.3:     2)

Test suite results on amd64-freebsd13:

  Passed: 2420 (14.0.3: 2420)
  Failed:    3 (14.0.3:    3)

Uploaded:

SHA256 (clang+llvm-14.0.4-amd64-unknown-freebsd12.tar.xz) = 80814b7a7a56151b204aa8cb621df22c645f41c834920c3818d6b6eadb175a79
SHA256 (clang+llvm-14.0.4-amd64-unknown-freebsd13.tar.xz) = 282696627bb3f2d07dd38d7c67ecff97877f2b984d712dbcb506e3f0a63ad1f8

-Dimitry

PowerPC Linux binaries are clean and uploaded:

ad2c2e2ae52bdeaa64140db37b996a2b4061f33c  clang+llvm-14.0.4-powerpc64le-linux-ubuntu-18.04.5.tar.xz
cec11c39647deeea5957708fbf8f438ce01278a8  clang+llvm-14.0.4-powerpc64le-linux-rhel-8.4.tar.xz

Binaries were built and tested by @maryam.

Hi guys, I don’t know whether this issue is appropriate to be raised here. I have tested the llvm14.0.4 in the ByteDance internal codebase and found several assertion failures, see [clang::CodeGen] Assertion failure caused by "conversion to incomplete array" · Issue #55691 · llvm/llvm-project · GitHub.

This issue is related to opaque pointers, I have tried to backport several patches and found this work is not trivial as I thought. Any suggestions and will this issue be fixed later, like 14.0.5?

Thanks!

Hi,

If the work is not trivial to backport I doubt we would include it in 14.0.5. That period is almost coming to a close and 14.0.5 is the last point release for 14.x - so there will be no more space for fixes after that. I think it will have to wait for 15.x. But that’s just my opinion of course and @tstellar might think differently.

1 Like

I am not quite sure if this is the correct place to discuss about the build_llvm_release.bat script.

Few years ago @rgal noted that lld-link was not used in stage1, despite building it in stage0.
https://lists.llvm.org/pipermail/llvm-dev/2019-August/134393.html

At Sony we have tried the build_llvm_package.bat script and these are some points that may be we could consider:

  • As the script is part of the LLVM tree, there are users that can use it for their internal releases and benefit from features such as: create binary package, run the tests, etc.
  • Is is true that executing the whole script takes quite a long time. May be add some command line options to select the desired tasks.

These optional tasks can be:

  • Specify output directory.
  • Build 32 and/or 64 binaries.
  • Run the tests
  • Package the binaries.
  • Use lld-link in stage1

We have most of those changes implemented and if the community is interested we can submit a patch.

Thanks
Carlos

I am not quite sure if this is the correct place to discuss about the build_llvm_release.bat script.

A separate thread would probably have better visibility. In any case, I’m happy to see this discussion

We have most of those changes implemented and if the community is interested we can submit a patch.

I think that would be great. We (Linaro) have a hacked up copy of that script that we’re currently using for our Windows on Arm releases. We’d like to migrate back to the in-tree script, and some of the changes that you’re proposing sound like they could make it easier for us. So, +1.

@rovka, I have created a separate thread.

https://discourse.llvm.org/t/build-llvm-release-bat-script-options/63146