A problem with forEachConstructorInitializer

Your issue is most confusing. You will need to show us the matcher code you’re trying to get working.

I’ve been looking for the ‘forEachConstructorInitializer’ and it wasn’t in ASTMatchers.h. I’ve been trying to replace these files(macros, internal, matchfinder…) for the ones in the svn, but it didn’t work.

I don’t want you to be thinking on the matcher, but my matcher, trying to bind every constructor initializer for fields in the class, is:

constructorDecl(
isDefinition(),
anyOf(
hasAnyConstructorInitializer(isWritten()), has(compoundStmt(has(stmt())))
),
forEachConstructorInitializer(forField(decl().bind(“CI”)))
);

I have tried to change ‘forEachConstructorInitializer’ for ‘forEach(ctorInitializer)’, but the system can’t identify ctorInitializer neither! :S

As for your build issues: try doing a clean rebuild, i.e. reconfigure (or run cmake again), and then make. I have never used ninja, so no idea if the issue could be on that front. Also make sure that you’ve not accidentally corrupted your LLVM/Clang checkout… But I hope you already tried these.

I don’t know why, but if I run ninja with “sudo”, it works fine now.

El día 26 sep 2013 14:28, Gabor Kozar kozargabor@gmail.com escribió: