about lli targets

Hi All,

I am trying to work on some JIT project. However when I try to run the default build with lli, I got the following err/msgs:

./lli -march=arm 1.bc
./lli: error creating EE: No available targets are compatible with this -march, see -version for the available targets.

./lli -version
LLVM (http://llvm.org/):
LLVM version 3.4svn
DEBUG build with assertions.
Built Feb 21 2014 (10:20:28).
Default target: x86_64-apple-darwin13.0.0
Host CPU: corei7

After reading some of the docs, I thought that the default configure should have lli build for ARM support, not sure how to register the target like ARM… to use lli?

any hints?

Best

Kevin