About python requirement, can down to 2.6 for rhel 6?

Hello, I notice llvm begin require python atleast 2.7,
Then I saw the commit log

Require python 2.7.

We were already requiring 2.5, which meant that people on old linux distros
had to upgrade anyway.

Requiring python 2.6 will make supporting 3.X easier as we can use the 3.X
exception syntax.

According to the discussion on llvmdev, there is not much value is requiring
just 2.6, we may as well just require 2.7.

I’m using rhel 6 so the default python version is still 2.6,
down the requirement to 2.6 will help rhel 6 a little bit.

Here is python 2.7 features
https://docs.python.org/3/whatsnew/2.7.html
Is these fetures must be use?

Ofcource I can build python 2.7 myself or use rhel software collections,
but it will make the software I built on llvm require python 2.7 too.

If python 2.6 is ok I hope llvm require this version for the years until switch to python 3.

As I known SUSE 11 still use python 2.6 and will support until 2020 (same to python 2),
Python 2.6 still have wide usage for enterprise.
The previous discussion said rhel / centos 6 use python 2.4 but that’s not true, they use 2.6.5 when 6.0 come out.

Regards.

Own Ssh
ownsshaim@aol.com

As I known SUSE 11 still use python 2.6 and will support until 2020 (same
to python 2),
Python 2.6 still have wide usage for enterprise.
The previous discussion said rhel / centos 6 use python 2.4 but that's
not true, they use 2.6.5 when 6.0 come out.

Installing Python is trivial on any Linux box. Can you describe why this is
a specific problem for you w.r.t. LLVM?

Eli