Almost all lldb-mi tests failing from timeout

I tried to run the lldb-mi test on MacOS 57 of 68 error’d out with timeout issues. Is this the standard state of the tests or am I doing something wrong?

python dotest.py --executable ~/llama/build/main_debug/bin/lldb tools/lldb-mi/

Hello Chunk,

I checked them a few days ago on OSX and all lldb-mi tests passed. It’s weird that you see so many errors. Today I’ll check it again. Thanks for report.

Thanks,
Ilia

Seems that it’s lldb regression:

1 -file-exec-and-symbols a.out

2 (gdb)

3 ^done

4 (gdb)

5 =shlibs-added,shlib-info=[num=“1”,name=“a.out”,dyld-addr="-",reason=“dyld”,path="/Users/IliaK/p/llvm/tools/lldb/test/tools/lldb-mi/a.out",loa ded_addr="-",dsym-objpath="/Users/IliaK/p/llvm/tools/lldb/test/tools/lldb-mi/a.out.dSYM/Contents/Resources/DWARF/a.out"]

6 -break-insert -f main

7 ^done,bkpt={number=“1”,type=“breakpoint”,disp=“keep”,enabled=“y”,addr=“0xffffffffffffffff”,func=“main”,file=“main.cpp”,fullname="/Users/IliaK /p/llvm/tools/lldb/test/tools/lldb-mi/main.cpp",line=“15”,pending=[“main”],times=“0”,original-location=“main”}

8 (gdb)

9 =breakpoint-modified,bkpt={number=“1”,type=“breakpoint”,disp=“keep”,enabled=“y”,addr=“0xffffffffffffffff”,func=“main”,file=“main.cpp”,fullnam e="/Users/IliaK/p/llvm/tools/lldb/test/tools/lldb-mi/main.cpp",line=“15”,pending=[“main”],times=“0”,original-location=“main”}

10 -exec-run

11 Assertion failed: (!“bad_weak_ptr”), function shared_ptr, file /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain /usr/bin/…/include/c++/v1/memory, line 5174.

Thanks,
Ilia

Hello,

RE: Seems that it’s lldb regression:
I fixed it in r233258 (it was my error).

At the moment all lldb-mi tests pass for me on OS X:

./dotest.py -v --executable $BUILDDIR/bin/lldb tools/lldb-mi/

[…]

Ran 68 tests in 204.082s

OK (skipped=1, expected failures=3)

As you see I use the same command.

Could you provide test outputs (using the -t option)?

Thanks,
Ilia

I am still having difficult running tests on macos. I have tried running the tests manually both with my built lldb-mi and lldb

When running with lldb, I get the following issue:

Chucks-Mac-mini:lldb-mi chuckr$ <build_dir>/bin/lldb

(lldb) target create ./a.out

Current executable set to ‘./a.out’ (x86_64).

(lldb) process launch

error: process launch failed: unable to locate debugserver

(lldb)

Is there some step in testing I’m missing to get my built debuserver on the path?

On MacOSX you should be building and testing by doing:

cd lldb
xcodebuild -configuration Debug -target desktop
cd test
./dotest.py

Please don't test using a make/cmake/ninja builds as it won't test the LLDB.framework as it appears on MacOSX. The make/cmake/ninja stuff builds a flat lldb.so (no framework).

Greg

Hello Chuck,

I think the following command may help you:
export LLDB_DEBUGSERVER_PATH=/Applications/Xcode.app/Contents/SharedFrameworks/LLDB.framework/Resources/debugserver

Thanks,
Ilia