also ./configure not honoring a --without-ocaml as to doco

CFLAGS="-g0 -O2 -pipe " \
CPPFLAGS="-I/usr/include/c++/4.1.1/x86_64-redhat-linux/ " \
                 ./configure \
  ...
                --without-ocaml \
  ...

later

    ... make[3]: Leaving directory `/home/herrold/rpmbuild/BUILD/clang-20100603/bindings/ocaml/transforms'
make[2]: Leaving directory `/home/herrold/rpmbuild/BUILD/clang-20100603/bindings/ocaml'
/bin/sh: line 1: -d: command not found
make[1]: *** [regen-ocamldoc] Error 127
make[1]: Leaving directory
   `/home/herrold/rpmbuild/BUILD/clang-20100603/docs'
make: *** [install] Error 1
   error: Bad exit status from /var/tmp/rpm-tmp.73988 (%install)

I do not see a specific documentation suppressor for when
ocaml is not present

[herrold@centos-5 clang-20100325]$ ./configure --help 2>&1 | \
   grep -i caml
   --with-ocaml-libdir Specify install location for ocaml
     bindings (default
[herrold@centos-5 clang-20100325]$ ./configure --help 2>&1 | \
   grep -i without
   --without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
[herrold@centos-5 clang-20100325]$ ./configure --help 2>&1 | \
   grep -i doc
   --infodir=DIR info documentation [DATAROOTDIR/info]
   --mandir=DIR man documentation [DATAROOTDIR/man]
   --docdir=DIR documentation root [DATAROOTDIR/doc/-llvm-]
   --htmldir=DIR html documentation [DOCDIR]
   --dvidir=DIR dvi documentation [DOCDIR]
   --pdfdir=DIR pdf documentation [DOCDIR]
   --psdir=DIR ps documentation [DOCDIR]
   --enable-doxygen Build doxygen documentation (default is NO)
[herrold@centos-5 clang-20100325]$