another minor problem with the ocaml binding


I notice that Llvm.llvm_handle_to_type is actually defined to create a type handle from a type, rather than vice versa as its name would imply. Should I send a patch to change the name of the function to reflect its type better, or should I just lump it?

to me the name implies that it creates a handle to the type given, i guess if you look at it in context of the ocaml conversion functions some people may think otherwise.

The OCaml standard library uses a convention for conversion functions like this, and various OCaml programming tutorials recommend using the convention in application code.