Anyone who has built lldb successfully on RHEL 6.x?

/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/bits/shared_ptr.h: In member function ‘virtual void* std::_Sp_counted_deleter<_Ptr, _Deleter, _Alloc, _Lp>::_M_get_deleter(const std::type_info&)’:
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/bits/shared_ptr.h:146: error: cannot use typeid with -fno-rtti

This is a bug ing libstdc++ bundled with g++ 4.4.x. You need either to build lldb without -fno-rtti flag, or use libc++

On Linux, a newer GCC will be helpful; I have been able to build with gcc
4.6 and newer. Alternatively, if you can build clang by itself, you should
be able to use clang to build lldb assuming you have a more recent
standard library.

Dan

Hi Dan,

Thanks for responding. Regretably, using clang 3.3 to build lldb on RHEL 6.4 didn’t work out. I said so explicitly in my original post, extracted below for reference:

After reading the page: http://lldb.llvm.org/build.html, I have been trying to build lldb with the following two approaches:

(I) using llvm/clang 3.3 together with libc++/libc++abi so the build is free of libstdc++:

This is what I used to configure the build:

…/llvm/configure --prefix=/usr --enable-optimized --disable-assertions --enable-targets=host-only --enable-cxx11=yes --enable-libcpp=yes --with-extra-ld-options="-lc++abi"

The resulting Release/bin/lldb crashes even for simple things like help x-(

Yes. I did build and use libc++ 3.3 as well.

– Zack

Hi, I have not tried an LLDB build against libc++ (though I have tried the test suite). Can you try to reproduce the crash with a debug build?

If its crashing on startup, it may be a library issue; maybe also try running ldd on the binary and check the output appears sane...

Dan