Appropriate GCC version

Hi,
I’ve been wondering whether the current LLVM/Clang trunk can be
built with one of the recent GCC versions or only with the Clang 7 or
later. In order for OpenMP offload properly to work on ppc64le, CUDA
9.2.148 seems to require GCC 7.2.0, so when building LLVM/Clang,
do I need to say this specific GCC version at CMake configure time?

Thanks,
Itaru.