Attention bot owners

Hello all bots owners,

As all of you know we move to github monorepo very soon now.
We are actively working on the buildbot to prepare a solution to switch from SVN to github when time comes.

It would require some activity on your bots.

At this point it is clear that you would need to

  • Make sure you have reasonably recent version of git installed and in the system path for the buildbot account,
  • Once the transition to github is done, you would need to remove the old source code and build directory. This could be done later assuming you have enough room on that hard drive for two sets of the source and build files.

Thanks

Galina

Hi Galina,

Thanks for the heads up.

Hello all bots owners,

As all of you know we move to github monorepo very soon now.
We are actively working on the buildbot to prepare a solution to switch from SVN to github when time comes.

It would require some activity on your bots.

At this point it is clear that you would need to

* Make sure you have reasonably recent version of git installed and in the system path for the buildbot account,

What qualifies as reasonably recent? Does git 2.7.4 suffice?

Thanks,
Diana

Hi Diana,

git 2.7.4 should be fine.

Thanks

Galina

git 2.7.4 was released 17-Mar-2016.

Here is the git downloads page.

Neil Nelson

Great, thank you!

I was just asking because recently someone proposed adding git 2.9.3
as the minimum required version: https://reviews.llvm.org/D65436
(we're currently running 2.7.4 on our ARM/AArch64 buildbots).

The bot should only clone? Any git version that can clone a repo from GitHub should be fine here?