avoid building clang-13 32 bit runtimes

Hello,

I am trying to build clang-13 with OpenMP target offload. I am getting a failure when it is trying to build the i386 runtime, which I really don’t need:

In file included from /nobackupnfs2/gjost/clang-13/llvm-13.x/compiler-rt/lib/builtins/absvdi2.c:13:

In file included from /nobackupnfs2/gjost/clang-13/llvm-13.x/compiler-rt/lib/builtins/int_lib.h:93:

In file included from /usr/include/limits.h:26:

In file included from /usr/include/features.h:399:

/usr/include/gnu/stubs.h:7:11: fatal error: ‘gnu/stubs-32.h’ file not found

include <gnu/stubs-32.h>

^~~~~~~~~~~~~~~~

I only have a gnu/stubs-64.h

Is there a way to disable all 32 bit runtimes?

I am currently using these CMake options

CMAKE_OPTIONS="\

-DLLVM_ENABLE_PROJECTS=clang;clang-tools-extra\

-DLLVM_ENABLE_RUNTIMES=openmp;compiler-rt \

-DLLVM_TARGETS_TO_BUILD=X86;NVPTX \

#-DCMAKE_LIBRARY_PATH=‘${LD_LIBRARY_PATH};/lib64;${CUDA_PATH}/lib64/stubs’ \

-DCMAKE_LIBRARY_PATH=‘${CUDA_PATH}/lib64/stubs’ \

-DCMAKE_C_COMPILER=gcc\

-DCMAKE_CXX_COMPILER=g++ \

-DLLVM_ENABLE_BACKTRACES=ON \

-DLLVM_ENABLE_WERROR=OFF \

-DLLVM_ENABLE_RTTI=ON \

-DLIBOMP_FORTRAN_MODULES=ON \

-DOPENMP_ENABLE_LIBOMPTARGET=ON \

-DLIBOMPTARGET_NVPTX_COMPUTE_CAPABILITIES=35,60,70 \

-DCLANG_OPENMP_NVPTX_DEFAULT_ARCH=sm_70 "