[Bug 21930] New: SWIG generation dependencies are messed up in CMake

Bug ID 21930
Summary SWIG generation dependencies are messed up in CMake
Product lldb
Version unspecified
Hardware PC
OS Windows NT
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee zturner@google.com
Reporter zturner@google.com
CC lldb-dev@cs.uiuc.edu
Classification Unclassified

Frequently you can get into a situation where you have a 0 byte .pyd file for
the extension module.  I'm not sure what triggers this, perhaps a stale symlink
or something, but when it happens, LLDB starts up with some python errors.  The
only way to fix it is to physically delete both liblldb and the entire
lib\site-packages folder and then rebuild.  If you delete only one of the two,
it's not enough.  This means incremental builds are broken until you do this
manual step.

Zachary Turner changed bug 21930

What | Removed | Added |

  • | - | - |
    Status | NEW | RESOLVED |
    Resolution | — | FIXED |

Comment # 1 on bug 21930 from Zachary Turner

This has been fixed.