[Bug 22411] New: lldb-mi on FreeBSD does not respond immediately after -exec-run

Bug ID 22411
Summary lldb-mi on FreeBSD does not respond immediately after -exec-run
Product lldb
Version unspecified
Hardware PC
OS FreeBSD
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee lldb-dev@cs.uiuc.edu
Reporter emaste@freebsd.org
Classification Unclassified

lldb-mi appears to hang after "-exec-run". An extra newline causes the expected
output to come back.

feynman% bin/lldb-mi --interpreter
(gdb)
-file-exec-and-symbols /bin/ls
^done
-break-insert -f main
=breakpoint-modified,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="0xffffffff",func="main",file="ls.c",fullname="/tank/emaste/src/git-stable-10/bin/ls/ls.c",line="163",pending=["main"],times="0",original-location="main"}
^done,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="0xffffffff",func="main",file="ls.c",fullname="/tank/emaste/src/git-stable-10/bin/ls/ls.c",line="163",pending=["main"],times="1",original-location="main"}
-exec-run
<<< Got stuck here. I pressed enter again. >>>
^running
=thread-group-started,id="i1",pid="29492"
=thread-created,id="1",group-id="i1"
=thread-selected,id="1"
(gdb)
*running,thread-id="all"
(gdb)
(gdb)
*stopped,reason="breakpoint-hit",disp="del",bkptno="1",frame={addr="0x004023f1",func="main",args=[{name="argc",value="1"},{name="argv",value="0x00007fffffffe580"}],file="ls.c",fullname="/tank//emaste/src/git-stable-10/bin/ls/ls.c",line="163"},thread-id="1",stopped-threads="all"
(gdb)
(gdb)
*running,thread-id="all"
(gdb)
(gdb)
*stopped,reason="breakpoint-hit",disp="del",bkptno="1",frame={addr="0x004023f1",func="main",args=[{name="argc",value="1"},{name="argv",value="0x00007fffffffe580"}],file="ls.c",fullname="/tank//emaste/src/git-stable-10/bin/ls/ls.c",line="163"},thread-id="1",stopped-threads="all"
(gdb)