[Bug 23318] New: SendSignalTestCase.test_with_dwarf_and_run_command fails on FreeBSD with "False is not True : It was the running state"

Bug ID 23318
Summary SendSignalTestCase.test_with_dwarf_and_run_command fails on FreeBSD with “False is not True : It was the running state”
Product lldb
Version unspecified
Hardware PC
OS FreeBSD
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee lldb-dev@cs.uiuc.edu
Reporter emaste@freebsd.org
Classification Unclassified

['dotest.py', '--executable', '/tank/emaste/src/llvm/build-nodebug/bin/lldb',
'-C', '/usr/bin/clang', '-v', '-t', '-f',
'SendSignalTestCase.test_with_dwarf_and_run_command']
LLDB library dir: /tank/emaste/src/llvm/build-nodebug/bin
LLDB import library dir: /tank/emaste/src/llvm/build-nodebug/bin
lldb version 3.7.0 (file:///tank/emaste/ctsrd/llvm/tools/lldb revision
964c7baae9bb99b66541b738fec5a15563ff783b clang revision
dd46e00897edba2e01e1d48eb39071f0bbd6c25c)
lldb.pre_flight: None
lldb.post_flight: None
python2.7 SBCommandInterpreter(0x801c6ac00)::HandleCommand (command="log enable
-n -f /dev/stderr lldb api verbose", SBCommandReturnObject(0x801c27b80):
Status:  Success, add_to_history=0) => 1
python2.7 SBCommandInterpreter::SBCommandInterpreter (interpreter=0x0) =>
SBCommandInterpreter(0x0)
python2.7 SBDebugger(0x801d0bb80)::GetCommandInterpreter () =>
SBCommandInterpreter(0x801c6ac00)
python2.7 SBCommandInterpreter(0x801c6ac00)::HandleCommand (command="setting
set target.prefer-dynamic-value no-dynamic-values",
SBCommandReturnObject(0x801c27b80), add_to_history=0)
python2.7 SBCommandInterpreter(0x801c6ac00)::HandleCommand (command="setting
set target.prefer-dynamic-value no-dynamic-values",
SBCommandReturnObject(0x801c27b80): Status:  Success, add_to_history=0) => 2

Session logs for test failures/errors/unexpected successes will go into
directory '2015-04-22-13_03_49'
Command invoked: dotest.py --executable
/tank/emaste/src/llvm/build-nodebug/bin/lldb -C /usr/bin/clang -v -t -f
SendSignalTestCase.test_with_dwarf_and_run_command
compilers=['/usr/bin/clang']

Configuration: arch=amd64 compiler=/usr/bin/clang