[Bug 23703] New: libedit is used during linking with CMake LLDB_DISABLE_LIBEDIT=1

Bug ID 23703
Summary libedit is used during linking with CMake LLDB_DISABLE_LIBEDIT=1
Product lldb
Version 3.6
Hardware PC
OS Linux
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee lldb-dev@cs.uiuc.edu
Reporter eugene.zelenko@gmail.com
Classification Unclassified

libedit is not installed by administrators, so I'm tried to set
LLDB_DISABLE_LIBEDIT=1 in CMake parameters. Compilation was OK but libedit was
used during linking because it is specified in LLDBDependencies.cmake
unconditionally.

Probably same issue will be for libncurces when LLDB_DISABLE_CURSES=1.

labath@google.com changed bug 23703

What | Removed | Added |

  • | - | - |
    Status | NEW | RESOLVED |
    CC | | labath@google.com |
    Resolution | — | WORKSFORME |

Comment # 1 on bug 23703 from labath@google.com

As far as I can see, linking with libedit is disabled properly:
  if (NOT LLDB_DISABLE_LIBEDIT)
    list(APPEND LLDB_SYSTEM_LIBS edit)
  endif()