[Bug 24679] New: Remove pexpect dependency from tests unless it's absolutely necessary

Bug ID 24679
Summary Remove pexpect dependency from tests unless it’s absolutely necessary
Product lldb
Version unspecified
Hardware All
OS All
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee lldb-dev@lists.llvm.org
Reporter zturner@google.com
CC llvm-bugs@lists.llvm.org
Classification Unclassified

pexpect should only be used in tests that require by definition the ability to
launch an lldb.exe from the command line in order to test argument parsing,
etc.  There are tests that use pexpect anyway even though this is not required.
 Those tests should be re-written using the SB API, or if that is not possible,
unit tests.

For starters, this includes the tests in TestCompletion.py, but new instances
of this occuring should be added to this bug for tracking.