[Bug 46613] New: LLDB does not load debug symbols on Windows 10

Bug ID 46613
Summary LLDB does not load debug symbols on Windows 10
Product lldb
Version 10.0
Hardware PC
OS Windows NT
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee lldb-dev@lists.llvm.org
Reporter joe@jrm.dev
CC jdevlieghere@apple.com, llvm-bugs@lists.llvm.org

Trying to explore a full LLVM toolchain for my C/C++ development on Windows,
and found that LLDB cannot load debug symbols on Windows 10. LLDB is producing
.PDB and .ILK files for the executable I want to debug, but when LLDB loads the
executable, no debug symbols are loaded.

Issues I experienced that lead me to realize the symbols weren't being loaded:
 - Could not set breakpoints (LLDB reported "Unable to resolve breakpoint to
any actual location").
 - Could not see source listing (LLDB command 'source list' did not output

Attempted fixes:
 - I tried rolling back to LLVM 6.0, to see if the issue was isolated to LLVM
10.0. Found that the issue persisted. I got curious and installed LLVM 10 and
LLVM 6 on my WSL terminal and found that both the 10.0 LLDB and the 6.0 LLDB
worked as expected, so I can only assume the issue is isolated to Windows.
 - Tried passing -gdwarf and -glldb to the Windows version of clang, but LLDB
was still not able to load debug symbols.

There is a duplicate of this bug (#42160) dating little more than year old
(posted 2019-06-06) that has reported this issue but didn't receive any

 - Is there anyone available to work on this? If not, I would gladly help out.
 - Is there any way to get verbose logging from LLDB? That would greatly help
me troubleshoot the source of the issue.