[Bug 51832] New: lldb/jit not working Windows

Bug ID 51832
Summary lldb/jit not working Windows
Product lldb
Version unspecified
Hardware PC
OS Windows NT
Status NEW
Severity release blocker
Priority P
Component All Bugs
Assignee lldb-dev@lists.llvm.org
Reporter steve@advance-software.com
CC jdevlieghere@apple.com, llvm-bugs@lists.llvm.org

Web Assembly (wasmtime) JIT debugging via lldb GDP/JIT interface not working on
Windows (trunk). 

Confirmed works Linux (llvm 10 - trunk status currently unknown on Linux).

Tried the following on Windows, using llvm trunk :
[https://www.youtube.com/watch?v=PevI_Mn-UUE](https://www.youtube.com/watch?v=PevI_Mn-UUE)

On Windows (running Windows 11 pre-release), the breakpoint isn't hit despite
it being the exact same test.

Tried llvm lldb/jit unit test on Windows.

I get the following : [https://controlc.com/40a36c4d](https://controlc.com/40a36c4d)

... from executing test directly. 

Specific test filtered using :

set LIT_FILTER=Breakpoint/jit-loader_rtdyld_elf.test

Unit test fails. Failure appears to be in lli which sets up the test
environment.

It appears we have 2 bugs.

1. JIT breakpoints not getting hit

2. lli failing meaning unit test can't complete to confirm or otherwise whether
JIT debugging is working on Windows.

The following appeared to complete successfully - indicating required plugin
available.

(lldb)  settings set plugin.jit-loader.gdb.enable on

However available & functioning are not the same thing.

To run same test on Linux - to confirm wasmtime is setting up debug environment
correctly, the following can be used - binary or buld from source  :

[https://github.com/bytecodealliance/wasmtime/releases/tag/v0.29.0](https://github.com/bytecodealliance/wasmtime/releases/tag/v0.29.0)

... in addition to the fizzbuzz.zip attachment which provides reproducible test
files & executibles on Windows.