[BUG] Regression: unprintable characters displayed

Hi,

This does not happen with lldb-330.0.48, which ships with OS X, but
happens with HEAD:

    frame #0: 0x0000000101c3ce8c libmwcgir_vm_rt.dylib`(anonymous
namespace)::CgJITMemManager::endFunctionBody(this=0x000000010a715610,
F=0x000000010a6da200, FunctionStart="�?^\n\x01",
FunctionEnd="����������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������...")
+ 28 at CgJITMemoryManager.cpp:437

We can easily detect if the characters are printable or not , no?
FunctionStart and FunctionEnd are uint8_t *.

Ram

Can you provide a test case, steps, and expected results please?