build error

Hi, I get the following build error when trying to make libclc (svn
revision 235353):

$ make
LLVM-AS generic--/lib/subnormal_disable.bc
LLVM-AS generic--/lib/subnormal_use_default.bc
LLVM-CC nvptx--nvidiacl/lib/synchronization/barrier.cl.bc
LLVM-CC nvptx--nvidiacl/lib/workitem/get_group_id.cl.bc
LLVM-CC nvptx--nvidiacl/lib/workitem/get_local_id.cl.bc
LLVM-CC nvptx--nvidiacl/lib/workitem/get_local_size.cl.bc
LLVM-CC nvptx--nvidiacl/lib/workitem/get_num_groups.cl.bc
LLVM-AS nvptx--nvidiacl/lib/integer/add_sat.ll.bc
LLVM-AS nvptx--nvidiacl/lib/integer/sub_sat.ll.bc
LLVM-CC nvptx--nvidiacl/lib/subnormal_config.cl.bc
LLVM-AS nvptx--nvidiacl/lib/subnormal_helper_func.ll.bc
/home/fhess/install/llvm/bin/llvm-as:
./generic/lib/subnormal_helper_func.ll:4:21: error: expected value
token
  %disable = load i1, i1* @__CLC_SUBNORMAL_DISABLE
                    ^
make: *** [nvptx--nvidiacl/lib/subnormal_helper_func.ll.bc] Error 1

Hello

Are you using LLVM < 3.6.0 ?

Changing the line to

%disable = load i1* @__CLC_SUBNORMAL_DISABLE

fixes compile with llvm 3.6. It appears you are using the load syntax
for llvm 3.7. Is llvm 3.7 the version I am supposed to use? The
configure.py script still seems to check for 3.6.

According http://llvm.org/viewvc/llvm-project?view=revision&revision=225041

> Changing the line to
>
> %disable = load i1* @__CLC_SUBNORMAL_DISABLE
>
> fixes compile with llvm 3.6. It appears you are using the load syntax
> for llvm 3.7. Is llvm 3.7 the version I am supposed to use? The
> configure.py script still seems to check for 3.6.

According http://llvm.org/viewvc/llvm-project?view=revision&revision=225041
---
Require LLVM 3.6 and bump version to 0.1.0

Some functions are implemented using hand-written LLVM IR, and
LLVM assembly format is allowed to change between versions, so we
should require a specific version of LLVM.

I think the problem is that the newly added code only works with LLVM 3.7+
Prior to that ToT libclc worked with 3.6 an 3.7.

-Tom

Changing the line to

%disable = load i1* @__CLC_SUBNORMAL_DISABLE

fixes compile with llvm 3.6. It appears you are using the load syntax
for llvm 3.7. Is llvm 3.7 the version I am supposed to use? The
configure.py script still seems to check for 3.6.

According http://llvm.org/viewvc/llvm-project?view=revision&revision=225041
---
Require LLVM 3.6 and bump version to 0.1.0

Some functions are implemented using hand-written LLVM IR, and
LLVM assembly format is allowed to change between versions, so we
should require a specific version of LLVM.

I think the problem is that the newly added code only works with LLVM 3.7+
Prior to that ToT libclc worked with 3.6 an 3.7.

In that case could we make a branch for the last known good commit for 3.6
(like we did for 3.5), and update configure to require 3.7?

Jeroen