build the llvm-gcc from source, error occur.

I first install the gcc-4.2.4 .
then I set CC and CXX
export CC= “path of my gcc-4.2.4”
export CXX=“path of my g+±4.2.4”

after that , I config and make .
error occur like this :
/home/ws/software/gcc-4-2/bin/gcc -c -g -O2 -DIN_GCC -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wmissing-format-attribute -DHAVE_CONFIG_H -I. -Ijava -I…/…/llvm-gcc4.2-2.5.source/gcc -I…/…/llvm-gcc4.2-2.5.source/gcc/java -I…/…/llvm-gcc4.2-2.5.source/gcc/…/include -I…/…/llvm-gcc4.2-2.5.source/gcc/…/libcpp/include -I…/…/llvm-gcc4.2-2.5.source/gcc/…/libdecnumber -I…/libdecnumber -I/home/ws/software/build-llvm-gcc/…/build-llvm//include -I/home/ws/software/llvm-2.5/include -DENABLE_LLVM -I/home/ws/software/build-llvm/…/llvm-2.5/include -D_DEBUG -D_GNU_SOURCE -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS …/…/llvm-gcc4.2-2.5.source/gcc/java/lang.c -o java/lang.o
…/…/llvm-gcc4.2-2.5.source/gcc/java/lang.c: In function‘java_init’中:
…/…/llvm-gcc4.2-2.5.source/gcc/java/lang.c:378: error:‘force_align_functions_log’not declare ( occur first in the function)

what matter I only enable-language c, c++, ada tube java ?

2009/9/4 Sheng Wang <wansheg@gmail.com>

…/…/llvm-gcc4.2-2.5.source/gcc/java/lang.c: In function‘java_init’中:
…/…/llvm-gcc4.2-2.5.source/gcc/java/lang.c:378: error:‘force_align_functions_log’not declare ( occur first in the function)

what matter I only enable-language c, c++, ada tube java ?

I don’t think Java is supported in llvm-gcc. Here is the information for building llvm-gcc with C, C++ and/or Ada support: http://llvm.org/docs/GCCFEBuildInstrs.html .

I first install the gcc-4.2.4 .
then I set CC and CXX
     export CC= "path of my gcc-4.2.4"
     export CXX="path of my g++-4.2.4"

after that , I config and make .
error occur like this :
/home/ws/software/gcc-4-2/bin/gcc -c -g -O2 -DIN_GCC -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wmissing-format-attribute -DHAVE_CONFIG_H -I. -Ijava -I../../llvm-gcc4.2-2.5.source/gcc -I../../llvm-gcc4.2-2.5.source/gcc/java -I../../llvm-gcc4.2-2.5.source/gcc/../include -I../../llvm-gcc4.2-2.5.source/gcc/../libcpp/include -I../../llvm-gcc4.2-2.5.source/gcc/../libdecnumber -I../libdecnumber -I/home/ws/software/build-llvm-gcc/../build-llvm//include -I/home/ws/software/llvm-2.5/include -DENABLE_LLVM -I/home/ws/software/build-llvm/../llvm-2.5/include -D_DEBUG -D_GNU_SOURCE -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS ../../llvm-gcc4.2-2.5.source/gcc/java/lang.c -o java/lang.o
../../llvm-gcc4.2-2.5.source/gcc/java/lang.c: In function¡®java_init¡¯ÖУº
../../llvm-gcc4.2-2.5.source/gcc/java/lang.c:378: error£º¡®force_align_functions_log¡¯not declare ( occur first in the function)
.............

what matter I only enable-language c, c++, ada tube java ?

Please follow the directions in the README.LLVM file (in llvm-gcc src) exactly. It will tell you what languages to enable (never java). If you do not follow it exactly, you will most likely run into problems.

-Tanya