Buildbot flakey test status

Hi all,

I’ve already marked most of these as XFAIL and added details with the XFAIL or in a bug associated with the XFAIL

Format:

Darwin
2969 dosep timeout (30 minutes)
This is the second dosep timeout I’ve seen. It’s very strange. All of the expected log files exist and are of the expected size (so all of the XFAIL, skip tests ran). Needs more investigation.

2961 TestGdbRemote_qThreadStopInfo.py
make MAKE_DSYM=YES ARCH=x86_64 CC=“clang” failed

2983 TestGdbRemote_vCont.py:111 buildDSym
make MAKE_DSYM=YES ARCH=x86_64 CC=“clang” failed

2909 TestGdbRemote_vCont.py:113
TestGdbRemote_vCont.test_single_step_only_steps_one_instruction_with_vCont_s_thread_debugserver_dsym
AssertionError: ‘$ENo such file or directory (/Users/lldb_build/lldbSlave/buildDir/lldb.src/test/tools/lldb-server/a.out)’ != ‘$OK’

2883 TestGdbRemote_vCont.py:111 buildDSym
make MAKE_DSYM=YES ARCH=x86_64 CC=“clang” failed

2860 TestFloatTypes.py
test_double_type_from_block_with_dsym (TestFloatTypes.FloatTypesTestCase)
AssertionError: False is not True : ‘frame variable --show-types a_union_nonzero_ref.u.a’ matches the output (from compiled code): 11001110

2852 TestGdbRemote_vCont.py
AssertionError: ‘$ENo such file or directory (/Users/lldb_build/lldbSlave/buildDir/lldb.src/test/tools/lldb-server/a.out)’ != ‘$OK’

2844 TestGdbRemote_vCont.py:113
AssertionError: ‘$ENo such file or directory (/Users/lldb_build/lldbSlave/buildDir/lldb.src/test/tools/lldb-server/a.out)’ != ‘$OK’

2843 TestCallWithTimeout.py:82
ExprCommandWithTimeoutsTestCase.test_with_dsym
self.assertTrue(value.IsValid())

Linux
2431 TestThreadSpecificBreakpoint.py - Got a FAIL result, marked as XFAIL, must have crashed
2427 TestGdbRemoteAuxvSupport.py
2395 TestInlineStepping.py
2367 TestExprDoesntBlock.py:61 ExprDoesntDeadlockTestCase.test_with_dwarf_and_run_command i386-clang