Building Clang with Clang (Self-Host)

Hello Everyone!

Do I need some special configuration if I want to build llvm(+clang)
with clang? Found no specific information, just that it should be
possible (Blog-Entry). Just setting CXX=clang didn't work for me.

I am using the latest svn version. First clang was built with gcc
(Ubuntu 4.4.1-4ubuntu9) 4.4.1.

If this was topic covered by another post or anywhere else then sorry
for the noise.

Thanks in advance,
Josef

Hello Everyone!

Do I need some special configuration if I want to build llvm(+clang)
with clang? Found no specific information, just that it should be
possible (Blog-Entry). Just setting CXX=clang didn't work for me.

I do that by rewriting CC/CXX in Makefile.config

I am using the latest svn version. First clang was built with gcc
(Ubuntu 4.4.1-4ubuntu9) 4.4.1.

If this was topic covered by another post or anywhere else then sorry
for the noise.

selfhosting is currently broken on ELF platforms - see bug 6353

Roman Divacky wrote:

Hello Everyone!

Do I need some special configuration if I want to build llvm(+clang)
with clang? Found no specific information, just that it should be
possible (Blog-Entry). Just setting CXX=clang didn't work for me.

I do that by rewriting CC/CXX in Makefile.config

Oh, my mistake. I set CXX=clang instead of CXX=clang++. Changing that
resolved my linker problems...

I am using the latest svn version. First clang was built with gcc
(Ubuntu 4.4.1-4ubuntu9) 4.4.1.

If this was topic covered by another post or anywhere else then sorry
for the noise.

selfhosting is currently broken on ELF platforms - see bug 6353

Thanks for the pointer. It seems my system is effected by this bug.

Roman Divacky wrote:

Hello Everyone!

Do I need some special configuration if I want to build llvm(+clang)
with clang? Found no specific information, just that it should be
possible (Blog-Entry). Just setting CXX=clang didn't work for me.

I do that by rewriting CC/CXX in Makefile.config

Oh, my mistake. I set CXX=clang instead of CXX=clang++. Changing that
resolved my linker problems...

I recommend

  CC=clang CXX=clang++

I am using the latest svn version. First clang was built with gcc
(Ubuntu 4.4.1-4ubuntu9) 4.4.1.

If this was topic covered by another post or anywhere else then sorry
for the noise.

selfhosting is currently broken on ELF platforms - see bug 6353

Thanks for the pointer. It seems my system is effected by this bug.

All Linux systems will be affected; Darwin (Mac OS) systems will not be affected.

  - Doug