Building llvm 1.8a on apple x86

I'm really sorry for the wide e-mail, but I've exhausted the normal channels.

I get:

llvm[2]: Linking Release executable tblgen (without symbols)
llvm[2]: ======= Finished Linking Release Executable tblgen (without symbols)
llvm[2]: Compiling fpcmp.cpp for Release build
llvm[2]: Linking Release executable fpcmp (without symbols)
llvm[2]: ======= Finished Linking Release Executable fpcmp (without symbols)
llvm[2]: Compiling PerfectShuffle.cpp for Release build
llvm[2]: Linking Release executable llvm-PerfectShuffle (without symbols)
llvm[2]: ======= Finished Linking Release Executable llvm-PerfectShuffle (without symbols)
llvm[1]: Building Intrinsics.gen.tmp from Intrinsics.td
make[1]: *** [/Users/rcleven/Desktop/llvm/build/lib/VMCore/Release/Intrinsics.gen.tmp] Segmentation fault

when building llvm on x86.

Am I doing something wrong? I've got the 1.8a package and 1.8 front end.

I've looked through every document i could find, every FAQ and I've reviewed the mailing list for a few weeks and can't find any

Thanks in advance,
Ryan.

Hi Ryan,

I couldn't replicate this situation on Linux. To diagnose we're going to
need more information. If possible, could you get a back trace on the
seg fault? Here's how you can do that:

cd {objdir}/lib/VMCore/
rm Release/Intrinsics.gen.tmp
make VERBOSE=1

The verbose output from "make" will give you the command line that is
failing. Next you need to run tblgen under the debugger:

gdb {objdir}/Release/bin/tblgen

Then, run the program with the options given from the verbose output
(just cut and paste them) using the "run" command:

run {options}

When the program stops, just get a backtrace with the "bt" command.

When you've got that information, file a bug report at
http://llvm.org/bugs/, describe the circumstance (tblgen failure) and
paste in the backtrace.

Once we have this information we should be able to track it down.

Thanks for the report.

Reid.