Building llvm and cfrontend under cygwin

Hi there,

I'm trying to build llvm under cygwin running under windows xp, and have
struck the following problem:
-- llvm: tools-only built ok
-- cfrontend: built ok
-- llvm: full build failed at the following point:

make[3]: Entering directory
`/cygdrive/d/3rd-party/llvm/runtime/GCCLibraries/crtend'
Compiling crtend.c to bytecode
Compiling listend.ll to bytecode
Linking comp_main.bc component...
/cygdrive/d/3rd-party/llvm/tools/Debug/gccld: Error linking in bytecode
file
'/cygdrive/d/3rd-party/llvm/runtime/GCCLibraries/crtend/BytecodeObj/crte
nd.bc': Bytecode file
'/cygdrive/d/3rd-party/llvm/runtime/GCCLibraries/crtend/BytecodeObj/crte
nd.bc' could not be loaded: Invalid Top Level Block Length! Type:1,
Size:880
(Vers=16, Pos=12)
make[3]: ***
[/cygdrive/d/3rd-party/llvm/runtime/GCCLibraries/crtend/BytecodeObj/comp
_main.bc] Error 1
make[3]: Leaving directory
`/cygdrive/d/3rd-party/llvm/runtime/GCCLibraries/crtend'
make[2]: *** [crtend/.makeall] Error 2
make[2]: Leaving directory
`/cygdrive/d/3rd-party/llvm/runtime/GCCLibraries'
make[1]: *** [GCCLibraries/.makeall] Error 2
make[1]: Leaving directory `/cygdrive/d/3rd-party/llvm/runtime'
make: *** [all] Error 1

Any clues? Here are a few bits of information that may be relevant:
-- I'm using gcc 3.3.3 (cygwin special)
-- I have changed gcc.c as per

http://mail.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20040809/0171
43.html

Thanks in advance,
Oleg.

Well, somehow the crtend.bc is getting corrupted. Here's some things to
check:

1. Make sure your path now includes <builddir>/Debug/bin instead of
    <builddir>/tools/Debug. This changed a little while back.
2. Make sure you aren't trying to link in some old/crufty crtend.bc
    file. Try doing "make uninstall ; make clean" in your crtend
    directory if you think this might be the case.

If those don't clear the problem, please tell me what version of LLVM
you're trying to compile (looks like 1.3) and send the output of:
  cd runtime ; make VERBOSE=1"

Thanks,

Reid.