Building LLVM and LLVM-GCC4 on Cygwin

Hello,

Well theres not too much to it. A patch for Cygwin’s stdint.h. And a patch for lib/System/Unix/Program.inc.

Despite Cygwin complaining of timing errors both LLVM and LLVM-GCC4 compile ok’ish.

make[2]: Warning: File `/dev/null’ has modification time 0.0096 s in the future
make[2]: warning: Clock skew detected. Your build may be incomplete.

I am getting this on both XP and Vista and am writting to the Cygwin list regarding this.

In Cygwin’s ‘include/stdint.h’ int32_t and uint32_t have to be changed from long’s to int’s.

http://www.aarongray.org/LLVM/Patches/stdint.h.diff

The alternative is to add some disambiguation functions to LLVM, these would be inline and transparent with no overhead.

And ‘lib/System/Unix/Program.inc’ has to have three lines #def’ed out on the Cygwin build.

http://www.aarongray.org/LLVM/Patches/Program.inc.diff

This is because Cygwin does not support RLIMIT_RSS.

There are ‘make check’ results here :-

http://www.aarongray.org/LLVM/check.txt

The summary :-

=== Summary ===

of expected passes 1620

of unexpected failures 136

of unexpected successes 1

of expected failures 19

Pritty rag tailed quite a few complaits and it also ended with errors.

There are build instructions here :-

http://www.aarongray.org/LLVM/BuildingLLVMonCygwin.html

Be aware with these timing errors Cygwin is not a solid development or build platform at present.

Release build coming soon :slight_smile:

Regards,

Aaron

This is invalidated as --enable-llvm switch was not included on the LLVM-GCC4 configuration. AND LLVM-GCC4 will not compile with GCC 3.4.4 (under Cygwin). :frowning:

Aaron