building llvm-gcc-4.2 with llvm installed

I tried constructing a llvm package for fink to
go with my llvm-gcc42 packaging this weekend. My hope
was that I could have the llvm package installed and
use those static libraries to build llvm-gcc-4.2 with
rather than rebuilding llvm again. Unfortunately,
--enable-llvm= seems to demand the llvm build directory.
Is this absolutely necessary or could the llvm-gcc-4.2
build be adjusted to work with just the installed llvm headers
and static libraries to compete the llvm-gcc-4.2 build?
Thanks in advance for any clarifications.
              Jack

If you have installed llvm binaries (llc, opt etc.. ) and headers in /usr/local/bin and /usr/local/include respectively then using --enable-llvm=/usr/local should work.