building llvm-gcc/llvm-g++

Hi,

I’m having trouble building the llvm-gcc frontend. I’m working with llvm-gcc4.2-2.5. I’m on 32bit x86 linux. I removed the file GNUmakefile, then built it with:

./configure --enable-languages=c,c++ --with-llvm=~/llvm/backend/llvm-2.5
make

~/llvm/backend/llvm-2.5 is where the backend was untared and built, but not installed.

After I’d done this there was a file in host-i686-pc-linux-gnu/gcc called xgcc. If I try to build with this however it won’t accept the --emit-llvm option with the error message:

xgcc: --emit-llvm is not supported in this configuration.

What option should I change in the configure command to get it to build in such a way that “–emit-llvm” will work?

Thanks,

Daniel Waterworth

Hello

./configure --enable-languages=c,c++ --with-llvm=~/llvm/backend/llvm-2.5
make

Please consider reading the documentation. E.g.
http://llvm.org/docs/GCCFEBuildInstrs.html

Hi Daniel,

I'm having trouble building the llvm-gcc frontend. I'm working with llvm-gcc4.2-2.5. I'm on 32bit x86 linux. I removed the file GNUmakefile, then built it with:

./configure --enable-languages=c,c++ --with-llvm=~/llvm/backend/llvm-2.5

it's --enable-llvm, not --with-llvm.

Ciao,

Duncan.

2009/10/14 Duncan Sands <baldrick@free.fr>

Hi Daniel,

I’m having trouble building the llvm-gcc frontend. I’m working with llvm-gcc4.2-2.5. I’m on 32bit x86 linux. I removed the file GNUmakefile, then built it with:

./configure --enable-languages=c,c++ --with-llvm=~/llvm/backend/llvm-2.5

it’s --enable-llvm, not --with-llvm.

Ciao,

Duncan.

Great, thanks a lot, I shall build again with that option.

Daniel