bump required cmake version

Hi all,

as ye-luo mentioned in ⚙ D82074 [OpenMP] Set cmake policies CMP0074 and CMP0075 to NEW, LLVM/12 bumps
the required cmake version to 3.13.4 . The OpenMP directory currently
sets the required cmake version to 2.8 . Any objections against bumping
the version also to 3.13.4? Or any other more up-to-date version? I
agree with the argument, that we shouldn't use a minimum version which
no one ever tests.

Best
Joachim

+1