Cannot Clone GitHub Repo

The title says it all. I get this every time I try to clone the repo. I don’t know how to get past it…I’m not even sure what it’s complaining about…

$ git clone https://github.com/llvm/llvm-project.git

Cloning into ‘llvm-project’…

remote: Enumerating objects: 2558, done.

remote: Counting objects: 100% (2558/2558), done.

remote: Compressing objects: 100% (90/90), done.

remote: Total 3544909 (delta 2489), reused 2493 (delta 2468), pack-reused 3542351

Receiving objects: 100% (3544909/3544909), 1.27 GiB | 5.67 MiB/s, done.

fatal: unable to open /Users/morbo/llvm/llvm-project/.git/objects/pack/tmp_pack_SVeS58: No such file or directory

fatal: index-pack failed

-bw

Hi Bill,

I just checked my Linux and macOS boxes. Both work.

Given that the error is a local filesystem path, does the directory `llvm-project` already exist on your filesystem before the `git clone`? If so, then you might try doing a `rm -rf llvm-project` right before doing `git clone https://github.com/llvm/llvm-project.git`

Dave

It didn’t exist. I tried it with “–recursive”, which was suggested to me, and it worked. I don’t know if it still fails without that flag, but at least I’m past this hurdle. :slight_smile:

-bw