cfe-users Digest, Vol 55, Issue 3 - Re: Missing header files in AST display

Thursday, August 3, 2017, 12:00:01 PM, you wrote:

> Send cfe-users mailing list submissions to

> To subscribe or unsubscribe via the World Wide Web, visit
> or, via email, send a message with subject or body ‘help’ to

> You can reach the person managing the list at

> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of cfe-users digest…"

> Today’s Topics:

> 1. Re: Missing header files in AST display
> (Raphael Isemann via cfe-users)


I was referring to the default include paths and your sample
command line did the trick and it all works well now. Thanks
a lot for your help.


> ----------------------------------------------------------------------

> Message: 1
> Date: Wed, 2 Aug 2017 22:46:02 +0200
> From: Raphael Isemann via cfe-users <>
> To: Ray Mitchell <>
> Cc:
> Subject: Re: [cfe-users] Missing header files in AST display
> Message-ID:
> <>
> Content-Type: text/plain; charset="UTF-8"

> Do you mean the default include paths? Not sure how the Windows
> version is handling this, but if a normal clang compilation works for
> you, then this should make the ast-dump working with all include
> default paths:

> clang -Xclang -ast-dump -fsyntax-only -I/your/usual/extra/paths test.c

> Note that there is no -cc1 but instead we only add the -ast-dump to
> the -cc1 invocation via -Xclang. This way you also get your default
> include paths from the driver.

> Otherwise you should write an example invocation that fails to find a
> certain header in a certain path, because with the current information
> it’s hard to say what exactly is going wrong.

> - Raphael

> 2017-08-02 20:07 GMT+02:00 Ray Mitchell via cfe-users
> <>:
>> I can currently successfully compile and link C and C++ code on my Windows
>> 10 system but I would also like to be able to separately generate the AST
>> for each file. The command line below does display much of the AST but it
>> contains errors regarding missing header files that my files have included.
>> For normal compiling I use the -I dir option in the standard way to specify
>> header file paths but that does not seem to work with the command line
>> below. How should this be done?
>> clang -cc1 -ast-dump test.c

>> _______________________________________________
>> cfe-users mailing list

> ------------------------------

> Subject: Digest Footer

> _______________________________________________
> cfe-users mailing list

> ------------------------------

> End of cfe-users Digest, Vol 55, Issue 3
> ****************************************