Changing the CMake Cache variables

Hello Everyone,

Chandler noted that the variable naming convention for the CACHE variables needed prefixing and so I have changed all of them to UPPERCASE and prefixed with LLOMP_.

Also, I have changed any LIBIOMP_ variable to LLOMP_. There are still libiomp (library name, some openmp specific targets) references in the CMake system but those will be changed in a different patch.

I wanted to make sure with everyone that LLOMP_ was ok and also to warn about the change.

– Johnny

Hi Johnny,

As I recall, the libc++ variables start with LIBCXX_ and the compiler-rt variables start with COMPILER_RT_; why don't we settle on the new library name and then prefix these with LIB<NAME>_?


Sounds good to me. I can change this easily enough.

-- Johnny