Clang and SSE4 error: “SSE4A instruction set not enabled”

I’m attempting to compile some code using VC11 built Clang but I get the result below. Preferably I would like to enable SSE4 (though I really just want my code to compile at all without errors) but none of the arguments I’ve tried have changed the error result. The code is nothing special, just an exported function and includes for map and vector. Thanks a lot in advance for any assistance.

C:\Program Files (x86)\LLVM\vs11\bin\Debug>clang++ -march=corei7 -mavx -mpclmul -msse4 -std=c++11 -c -~~fms~~<s>-compatibility -fms-extensions -v -o simple.o simple.cpp 
clang version 3.4 (trunk)
Target: i686-pc-win32
Thread model: posix
 "C:/Program Files (x86)/LLVM/vs11/bin/Debug/clang++.exe" -cc1 -triple i686-pc-win32 -emit-obj -mrelax-all -disable-free -main-file-name simple.cpp -mrelocation-static -mdisable-fp-elim -fmath-errno -masm-verbose -mconstructor-aliases -target-cpu corei7 -target-feature +avx -target-featur
e +pclmul -target-feature +sse4 -v -coverage-file simple.o -resource-dir "C:/Program Files (x86)/LLVM/vs11/bin/Debug\\..\\lib\\clang\\3.4" -internal-isystem "C:/Program Files (x86)/LLVM/vs11/bin/Debug/../lib/clang/3.4/include" -internal-isystem "C:\\Program Files (x86)\\Microsoft Visual Studio 11.0\\VC\\include" -internal-isystem "C:\\Program Files (x86)\\Windows Kits\\8.0\\\\include" -std=c++11 -fdeprecated-macro -ferror-limit 19 -fmessage-length  -mstackrealign -fms-extensions -fms-compatibility -fmsc-version=1300 -fdelayed-template-parsing -fobjc-runtime=gcc -fobjc-default!
 <s>-synthesize-properties -fcxx-exceptions -fexceptions -fdiagnostics-show-option -fcolor-diagnostics -backend-option -vectorize-loops -o simple.o -x c!
 <s>++ simple.cpp
clang -cc1 version 3.4 based upon LLVM 3.4svn default target i686-pc-win32
#include "..." search starts here:
#include <...> search starts here:
 C:/Program Files (x86)/LLVM/vs11/bin/Debug/../lib/clang/3.4/include
 C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include
 C:\Program Files (x86)\Windows Kits\8.0\\include
End of search list.
In file included from simple.cpp:2:
In file included from C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include\vector:6:
In file included from C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include\xmemory:6:
In file included from C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include\xmemory0:942:
In file included from C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include\intrin.h:27:
C:/Program Files (x86)/LLVM/vs11/bin/Debug/../lib/clang/3.4/include\ammintrin.h:28:2: error: "SSE4A instruction set not enabled"</s></s></s>

Compiling C++ with clang and the Visual C++ headers doesn’t work yet. intin.h is one of the blockers. It’s prototypes conflict with clang’s.

I’ve been working around it for now with a modified intrin.h that comes first on the include path.

Also, if you wish to link against the Visual C++ runtime, you’ll need to use ‘-Xclang -cxx-abi -Xclang microsoft’. Again, most things don’t work.