clang on win7 x64

Hi,

1

I have got llvm, test suite, clang from svn, buit them:
C:\llvm\LLVM\Debug>mingw32-make -j8 ENABLE_OPTIMIZED=0

and try to test, but:

C:\llvm\LLVM\Debug>mingw32-make check-all
mingw32-make: *** No rule to make target `check-all’. Stop.

C:\llvm\test>mingw32-make check-all
…/Makefile.common:61: …/Makefile.config: No such file or directory
…/Makefile.common:69: /Makefile.rules: No such file or directory
mingw32-make: *** No rule to make target `/Makefile.rules’. Stop.

2

When compiles:

c:\Users\Ariel>C:\LLVM-2.8\bin\clang test.c
c:/mingw/bin/…/lib/gcc/mingw32/4.5.0/…/…/…/…/mingw32/bin/ld.exe: –?—?–˜–?—?
–ø—?–˜–∂–?–˜–?–∏–˜: –? C:/Users/Ariel/AppData/Local/Temp/cc-000001.o –∏–∑–?–˜–?—
‘–? —’–∏–ø —?–∏–?–?–?–>–∞ `_main’ —? 32 –?–∞ 512

Nevertheless, programme works:

c:\Users\Ariel>C:\Users\Ariel\test.exe
hello world!

3

cmake did not create makefiles for some llvm tools such llvm-config, etc. So they where not built.

4

C_INCLUDE_DIRS:STRING=
by default compiler search headers in the mingw/include, does relative path work? …/include; …/clang2.9/include

As for #3, the CMake build doesn’t build llvm-config. Although it shouldn’t be too hard to add it.

1
I have got llvm, test suite, clang from svn, buit them:
C:\llvm\LLVM\Debug>mingw32-make -j8 ENABLE_OPTIMIZED=0
and try to test, but:
C:\llvm\LLVM\Debug>mingw32-make check-all
mingw32-make: *** No rule to make target `check-all'. Stop.
C:\llvm\test>mingw32-make check-all
../Makefile.common:61: ../Makefile.config: No such file or directory
../Makefile.common:69: /Makefile.rules: No such file or directory
mingw32-make: *** No rule to make target `/Makefile.rules'. Stop.

You haven't configured LLVM at all. Please consider reading e.g.
http://llvm.org/docs/GettingStarted.html#config

I configure llvm:

cmake -G “MinGW Makefiles” C:\llvm

these targets work: clean, install

You can try the ‘clang-test’ make target in the tools/clang/test subdirectory of your cmake project.

Michael Spencer <bigcheesegs@gmail.com>
writes:

As for #3, the CMake build doesn't build llvm-config. Although it
shouldn't be too hard to add it.

IIRC, building llvm-config on MinGW without MSYS was disabled because
the non-MSYS perl didn't work well.

Anyone with a MSYS-less MinGW build can test if this command works:

perl PATH_TO_LLVM_SOURCE_ROOT/utils/GenLibDeps.pl -flat <directory_with_libraries_in_it>

environment:

corei7, Win 7 x64, svn, cmake, python27, mingw32 (c, c++);

LLVM source = c:\llvm-2.8
LLVM build = c:\llvm-2.8\llvm\Debug

targets: check works (requires unix programmes), check-all, TEST=nightly report report.html doesn’t work neither in LLVM source\projects\test-suite nor LLVM build\projects\test-suite;

Maybe anyone knows how to configure clang’s search dirs to use RPATH, I mean somethink lik this: RPATH/…/include? If no, will gcc specs work?

-version shows thread model: posix, does it well or it must be win32 like in gcc?

Michael Spencer <bigcheesegs@gmail.com>
writes:

As for #3, the CMake build doesn’t build llvm-config. Although it
shouldn’t be too hard to add it.

IIRC, building llvm-config on MinGW without MSYS was disabled because
the non-MSYS perl didn’t work well.

Anyone with a MSYS-less MinGW build can test if this command works:

perl PATH_TO_LLVM_SOURCE_ROOT/utils/GenLibDeps.pl -flat <directory_with_libraries_in_it>

Is the difference between the use of cmake and ./configure via msys to llvm executables?