Clang support for Arch Linux


I need to apply the patch below in order for clang to work properly on
Arch Linux, due to errors finding crt*.o. I am not sure if this is
the best way to fix the issue, but it seems to work for me. I've
attached the patch as a file as well, since I know that GMail tends to
mangle them.

archlinux.patch (1.18 KB)

I don’t use ArchLinux, but this seems fairly reasonable to me. If any ArchLinux users pipe up to request a different approach I’m all ears, but for now I’ve committed your patch in r126476 (modulo sorting the enum). Please let me know if that works? I’d be interested to know that Clang is working mostly out-of-the-box on ArchLinux.


Hi Chandler,

I had submitted a patch a while back for this that didn’t get picked up, in order to compile anything c++ related I also needed to include the attached portion.

Note: I’ve only actually tried this on a 32-bit machine, but the 64bit path was what I saw in the arch package when I checked online.

Also, I didn’t need the Lib = “lib” chunk; although it doesn’t seem to break anything for me. Maybe that’s needed for the 64bit?


ArchInitHeaderSearch.patch (854 Bytes)

Yes, I am running 64-bit Arch Linux, and basically all libraries go in
/lib and /usr/lib, with the exception of a handful that go in /lib64.
I'm not sure why this is, but it seems to confuse the logic in the
ToolChains.cpp file into thinking it should use a "lib64" directory.

My patch was simply to force the use of "lib" on Arch Linux, so
hopefully that works for 32-bit and 64-bit.

I have not tried anything in C++ as of yet, so I would not have seen
the issue your patch addressed. Hopefully it can be added as well, as
I likely will encounter it at some point.