clang website error clang.llvm.org

Hi Jon,

This is a better question for the cfe-dev folks. I don’t use chrome (nor is my name Chrome :slight_smile:

-Chris

Did you know the website doesn’t fit on screen with Chrome? I had to zoom
the page out. This is because there seems to be a kind of “frame set” which
prevents the menu on the left from scrolling up. Can you fix it?

I see what you mean. The left hand menu is fixed, and cannot be scrolled

if it flows off the screen. This probably isn't Chrome specific.

http://clang.llvm.org/

Also, this page has been removed, http://clang.llvm.org/performance.html

Can you add a good 404 error page? Also, could you add the page back? Many
sites externally link to that. Perhaps symlink to the new page?

Symlink to http://clang.llvm.org/features.html#performance

The old performance.html page was an outdated comparison of the compile
time of Clang and GCC 4.2, which isn't really a fair comparison today. The
new one just says that performance is a goal of the clang project. Do you
think such a redirect would be useful?

Did you know the website doesn’t fit on screen with Chrome? I had to zoom the page out. This is because there seems to be a kind of “frame set” which prevents the menu on the left from scrolling up. Can you fix it?
I see what you mean. The left hand menu is fixed, and cannot be scrolled if it flows off the screen. This probably isn't Chrome specific.

http://clang.llvm.org/

Also, this page has been removed, http://clang.llvm.org/performance.html

Can you add a good 404 error page? Also, could you add the page back? Many sites externally link to that. Perhaps symlink to the new page?

Symlink to http://clang.llvm.org/features.html#performance

The old performance.html page was an outdated comparison of the compile time of Clang and GCC 4.2, which isn't really a fair comparison today. The new one just says that performance is a goal of the clang project. Do you think such a redirect would be useful?

I think a redirect is always good, for pages that have moved. External links will still be valid then.

Also maybe a nice 404 page with a link to main site front page would be good for pages that are really gone for ever.

Regards, Jon

Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered No. 04586709.

I submitted a patch making the menu not fixed in 2011 but it apparently was not checked in. The thread is/was “[cfe-commits] Website menu”. Vassil

Did you know the website doesn’t fit on screen with Chrome? I had to zoom the page out. This is because there seems to be a kind of “frame set” which prevents the menu on the left from scrolling up. Can you fix it?
I see what you mean. The left hand menu is fixed, and cannot be scrolled if it flows off the screen. This probably isn't Chrome specific.
I submitted a patch making the menu not fixed in 2011 but it apparently was not checked in. The thread is/was "[cfe-commits] Website menu".
Vassil

Hello Vassil
Perhaps you could re-commit. I see the site has same navigation problem today.
Regards, Jon

Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered No. 04586709.

I don’t have commit access but I am reattaching the fix again. I hope somebody commits it. Vassil

not_fixed_menu.diff (375 Bytes)

Commit as r231637. I confirm that it fixes the issue (Firefox). Thanks for the patch. Sylvestre

Thanks! Vassil

Did you know the website doesn’t fit on screen with Chrome? I had to zoom the page out. This is because there seems to be a kind of “frame set” which prevents the menu on the left from scrolling up. Can you fix it?
I see what you mean. The left hand menu is fixed, and cannot be scrolled if it flows off the screen. This probably isn't Chrome specific.
I submitted a patch making the menu not fixed in 2011 but it apparently was not checked in. The thread is/was "[cfe-commits] Website menu".
Vassil

Hello Vassil
Perhaps you could re-commit. I see the site has same navigation problem today.
I don't have commit access but I am reattaching the fix again. I hope somebody commits it.
Commit as r231637.
I confirm that it fixes the issue (Firefox).
Thanks!
Vassil

Unfortunately I see Chrome v40.0.2214.115 has same problem.
Any ideas?
Jon

Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered No. 04586709.