Comments sent via mail are not imported into Phabricator web

Hi Manuel,

I believe you’re maintaining Phabricator at reviews.llvm.org. Duncan likes to send his patch comments via email, like in the example below. Do you know why don’t his replies get imported into the web interface? The reply was sent to “reviews+D24569+public+a5763c0a090df06f@reviews.llvm.org”, and I bet that the purpose of this weird address is to match the revision this reply belongs to. I never saw any email reply actually appear in the web interface, and that sounds like a server misconfiguration.

Or is that something that Phabricator just doesn’t support?

Thanks,
Kuba

Hi Manuel,

I believe you’re maintaining Phabricator at reviews.llvm.org. Duncan likes to send his patch comments via email, like in the example below. Do you know why don’t his replies get imported into the web interface? The reply was sent to “reviews+D24569+public+a5763c0a090df06f@reviews.llvm.org”, and I bet that the purpose of this weird address is to match the revision this reply belongs to. I never saw any email reply actually appear in the web interface, and that sounds like a server misconfiguration.

Or is that something that Phabricator just doesn’t support?

Correct, phab doesn’t support in-line replies. Would be great to add it, but it’s quite a bit of development work.
Generally, email is the system of record, and phab exists to make email based reviews more convenient.

I filed this as https://llvm.org/bugs/show_bug.cgi?id=29038.

I thought at one point you could cc reviews+...@reviews.llvm.org to add
whole issue comments (not inline replies), but it doesn't seem to work for
me anymore.

Whatever happens, I'd like to document what is supposed to happen when you
reply by email to a phab review at http://llvm.org/docs/Phabricator.html.