Compiling lldb with Python2.6

Hello everyone,

Is it possible to build the python bindings with python 2.6 instead of 2.7 (on Lion)?

I tried setting the com.apple.versioner.python key "Version = 2.6" and changing the symlink in /System/Library/Frameworks/Python.framework/Versions/Current to the 2.6 version.

With those changes, the framework got built and I can import the module without any errors. I can also use lldb's functions, at least with HandleCommand() and the tutorials that are in the source base.

My problem is that everything is good if I don't run any program. If I try to use the 'run' command, or the target.LaunchSimple () method, the lldb library errors out with "Process must be launched" for commands like "bt", "n", "list".

The state is stuck at "launching", and I get the child program in an "uninterruptible sleep state" ('U' in ps).

I wanted to use the Python bindings with 2.6 because they would be called from a program that is compatible with Snow Leopard and Lion, so we can't be sure we will have python 2.7.

Any ideas on what went wrong or how to fix this problem?

Thanks in advance,

  Filipe

comments below