Compiling LLVM 3.5 in OsX Yosemite

Hi,

I am quite new to LLVM. I am trying to compile version 3.5 from source in OS X Yosemite, but the compilation fails when it tries to build the bindings for Ocaml. I suppose that this may already been posted in this list, sorry for that. Anyway, if someone can give me some pointers to what is causing the problem, I would appreciate it a lot.

I have compiled Ocaml from source, and also used a homebrew installation. In both cases, the bindings fail to compile. For the compilation process, I am using Appleā€™s LLVM.

Best regards,
David