Compiling VMKit in debug mode

Hello,

I am currently working on the latest version of VMKit (svn trunk). I need to debug VMKit so I tried compiling VMKit in debugging mode (ENABLE_OPTIMIZED=0). To do so I compiled LLVM in debug mode (yes, I really did it…) via:
./configure --enable-debug-runtime --enable-debug-symbols
make ENABLE_OPTIMIZED=0
It all went okay for LLVM.

Now I tried to compile VMKit in debug mode via:
./configure --with-llvmsrc=/home/koutheir/llvm --with-llvmobj=/home/koutheir/llvm --with-gnu-classpath-libs=/home/koutheir/classpath/lib --with-gnu-classpath-glibj=/usr/local/classpath/share/classpath/glibj.zip ENABLE_OPTIMIZED=0
make ENABLE_OPTIMIZED=0

The compilation failed in the file: “…/vmkit/lib/vmkit/CommonThread/Debug+Asserts/Sigsegv_gc.s” and said “file 1 already reserved” (or something alike).

I fixed the error by adding “19” on the first line of the file where appropriate. And then retried compiling:
And now, compilation fails in: Buildfile: /media/Data/Documents/PhD/VMKit/vmkit/mmtk/java/build.xml
And the error is:
[javac] /media/Data/Documents/PhD/VMKit/vmkit/mmtk/java/build.xml:4: warning: ‘includeantruntime’ was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
[javac] Compiling 760 source files to /media/Data/Documents/PhD/VMKit/vmkit/mmtk/java/classes
[javac] /media/Data/Documents/PhD/VMKit/vmkit/mmtk/java/src/org/j3/bindings/Bindings.java:40: duplicate class: org.j3.bindings.Bindings
[javac] public final class Bindings {
[javac] ^

And more similar errors for other classes are emitted.
What is the real problem here? I don’t understand why javac says the class is duplicate. I should note that compiling LLVM and VMKit in Release mode works.

Any ideas about this error?

Thank you.

Koutheir ATTOUCHI.
LinkedIn profile: http://tn.linkedin.com/in/koutheirattouchi