Configuration error in latest clang?

Hi,

I'm experiencing a basic clang failure after checking out the latest
llvm+clang. This problem is new for me in 2.9 as 2.8 seems to complete
successfully (see below). Any troubleshooting tips would be helpful. A
quick look through http://llvm.org/bugs/ didn't reveal any known
issues.

I'm following the procedure under the clang pages
(http://clang.llvm.org/get_started.html). The following picks up under
the heading "Clang Compiler Driver (Drop-in Substitute for GCC)" where
version information is displayed for reference:

[crc@lbrmn-crc apollo]$ cat t.c
#include <stdio.h>
int main(int argc, char **argv) { printf("hello world\n"); }

[crc@lbrmn-crc apollo]$ clang --version
clang version 2.9 (8af7990ac0648d176e6d300fcc0c2f171c0f287b)
Target: i386-pc-linux-gnu
Thread model: posix
[crc@lbrmn-crc apollo]$ clang -v t.c
clang version 2.9 (8af7990ac0648d176e6d300fcc0c2f171c0f287b)
Target: i386-pc-linux-gnu
Thread model: posix
"/home/crc/builds/llvm-build/Debug+Asserts/bin/clang" -cc1 -triple
i386-pc-linux-gnu -emit-obj -mrelax-all -disable-free -main-file-name
t.c -mrelocation-model static -mdisable-fp-elim -masm-verbose
-mconstructor-aliases -target-cpu pentium4 -target-linker-version
2.19.51.0.14 -v -resource-dir
/home/crc/builds/llvm-build/Debug+Asserts/bin/../lib/clang/2.9
-ferror-limit 19 -fmessage-length 90 -fgnu-runtime
-fdiagnostics-show-option -fcolor-diagnostics -o /tmp/cc-yXmlPJ.o -x c
t.c
clang -cc1 version 2.9 based upon llvm 2.9svn hosted on i386-pc-linux-gnu
#include "..." search starts here:
#include <...> search starts here:
/usr/local/include
/home/crc/builds/llvm-build/Debug+Asserts/bin/../lib/clang/2.9/include
/usr/include
End of search list.
"/usr/bin/ld" --eh-frame-hdr -m elf_i386 -dynamic-linker
/lib/ld-linux.so.2 -o a.out crt1.o crti.o crtbegin.o -L -L/../../..
/tmp/cc-yXmlPJ.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc
--as-needed -lgcc_s --no-as-needed crtend.o crtn.o
/usr/bin/ld: crt1.o: No such file: No such file or directory
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Compare this with a successful invocation using 2.8 release:

[crc@lbrmn-crc apollo]$ cat t.c
#include <stdio.h>
int main(int argc, char **argv) { printf("hello world\n"); }

[crc@lbrmn-crc apollo]$ clang --version
clang version 2.8 (branches/release_28)
Target: i386-pc-linux-gnu
Thread model: posix
[crc@lbrmn-crc apollo]$ clang -v t.c
clang version 2.8 (branches/release_28)
Target: i386-pc-linux-gnu
Thread model: posix
"/home/crc/builds/llvm-build-2.8/Release/bin/clang" -cc1 -triple
i386-pc-linux-gnu -S -disable-free -disable-llvm-verifier
-main-file-name t.c -mrelocation-model static -mdisable-fp-elim
-mconstructor-aliases -target-cpu pentium4 -target-linker-version
2.19.51.0.14 -v -resource-dir
/home/crc/builds/llvm-build-2.8/Release/lib/clang/2.8 -ferror-limit 19
-fmessage-length 90 -fgnu-runtime -fdiagnostics-show-option
-fcolor-diagnostics -o /tmp/cc-S34wkU.s -x c t.c
clang -cc1 version 2.8 based upon llvm 2.8 hosted on i386-pc-linux-gnu
#include "..." search starts here:
#include <...> search starts here:
/usr/local/include
/home/crc/builds/llvm-build-2.8/Release/lib/clang/2.8/include
/usr/include
End of search list.
"/usr/bin/as" --32 -o /tmp/cc-eVQ0CN.o /tmp/cc-S34wkU.s
"/usr/lib/ccache/gcc" -v -m32 -o a.out /tmp/cc-eVQ0CN.o
Using built-in specs.
Target: i586-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info
--with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap
--enable-shared --enable-threads=posix --enable-checking=release
--with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions
--enable-languages=c,c++,objc,obj-c++,java,fortran,ada
--enable-java-awt=gtk --disable-dssi --enable-plugin
--with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre
--enable-libgcj-multifile --enable-java-maintainer-mode
--with-ecj-jar=/usr/share/java/eclipse-ecj.jar
--disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic
--with-arch=i586 --build=i586-redhat-linux
Thread model: posix
gcc version 4.4.1 20090725 (Red Hat 4.4.1-2) (GCC)
COMPILER_PATH=/usr/libexec/gcc/i586-redhat-linux/4.4.1/:/usr/libexec/gcc/i586-redhat-linux/4.4.1/:/usr/libexec/gcc/i586-redhat-linux/:/usr/lib/gcc/i586-redhat-linux/4.4.1/:/usr/lib/gcc/i586-redhat-linux/:/usr/libexec/gcc/i586-redhat-linux/4.4.1/:/usr/libexec/gcc/i586-redhat-linux/:/usr/lib/gcc/i586-redhat-linux/4.4.1/:/usr/lib/gcc/i586-redhat-linux/
LIBRARY_PATH=/usr/lib/gcc/i586-redhat-linux/4.4.1/:/usr/lib/gcc/i586-redhat-linux/4.4.1/:/usr/lib/gcc/i586-redhat-linux/4.4.1/../../../:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS='-v' '-m32' '-o' 'a.out' '-mtune=generic' '-march=i586'
/usr/libexec/gcc/i586-redhat-linux/4.4.1/collect2 --eh-frame-hdr
--build-id -m elf_i386 --hash-style=gnu -dynamic-linker
/lib/ld-linux.so.2 -o a.out
/usr/lib/gcc/i586-redhat-linux/4.4.1/../../../crt1.o
/usr/lib/gcc/i586-redhat-linux/4.4.1/../../../crti.o
/usr/lib/gcc/i586-redhat-linux/4.4.1/crtbegin.o
-L/usr/lib/gcc/i586-redhat-linux/4.4.1
-L/usr/lib/gcc/i586-redhat-linux/4.4.1
-L/usr/lib/gcc/i586-redhat-linux/4.4.1/../../.. /tmp/cc-eVQ0CN.o -lgcc
--as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s
--no-as-needed /usr/lib/gcc/i586-redhat-linux/4.4.1/crtend.o
/usr/lib/gcc/i586-redhat-linux/4.4.1/../../../crtn.o

Thanks for any tips,
Chad