Configure broken

Hi,

The "Enforce python2 for systems that use python3 as their default.” commit breaks configure on Mac OSX. I get a:

env: python2: No such file or directory

I think this needs to be solved in a different way, but I’m not knowledgable enough about Python to come up with a patch.

Regards,

Jeroen