configure --enable-targets conflicts with the configure -target (SVN r152999)

Hello

I followed http://clang.llvm.org/get_started.html and I did a checkout of llvm and it’s tools. I am trying to enable arm support and therefore ran configure using the following option

…/llvm/configure --enable-targets x86,x86_64,arm but this does not work. It actually results is
checking build system type… Invalid configuration x86,x86_64,arm': machine x86,x86_64,arm’ not recognized
configure: error: /bin/sh …/llvm/autoconf/config.sub x86,x86_64,arm failed

This is caused by configure parsing the “-target” part in “–enable-targets” and trying to configure the “target” to be .x86,x86_64,arm this will not work
I am not sure how to fix this but I like to mention it so some autotools person can fix it

I worked around the issue by using some configure magic.

export enable_targets+set = “”
export enable_targets=x86,x86_64,arm
…/llvm/configure

Greetings

I think it is actually caused by you forgetting =
in --enable-targets=x86,x86_64,arm .

Hello

This is caused by configure parsing the “-target” part in
“–enable-targets” and trying to configure the “target” to be
.x86,x86_64,arm this will not work

I think it is actually caused by you forgetting =
in --enable-targets=x86,x86_64,arm .

Thanks that worked.

the documentation printed when running ./configure --help did not mention this. I suggest to include the documentation from
http://llvm.org/docs/GettingStarted.html in there

Greetings