configure with new target

Hello everyone!

I’ve started to implement a ColdFire backend, but there are some troubles during configuring:

$ …/llvm/configure --enable-targets=x86,x86_64,coldfire



checking whether byte ordering is bigendian… no
configure: error: Unrecognized target coldfire
configure: error: …/…/…/llvm/projects/sample/configure failed for projects/sample

I’ve added ColdFire to :

  1. TARGETS_TO_BUILD variable
  2. ‘case “$a_target” in’
  3. ‘case “$llvm_cv_target_arch” in’
  4. ‘case $target in’
  5. to ‘case $host in’

but it looks like more changes are needed.

Could someone, please, advise me?

Did you also update the configure.ac script in projects/sample/autoconf ?

-Tom

Did you check config.log? It has more detailed information about what it was doing. You could also try using shell's option "-x": sh -x ./configure <arguments>

-Krzysztof

llvm-build is used when ./configure-ing, right? Because when using
CMake, I also had to add the target to the subdirectory list in
lib/Target/LLVMBuild.txt.

By the way, this is the only problem I encountered with out-of-tree
targets: you can't just clone a target in lib/Target (or even
projects/) and get going, you also have to add it to LLVMBuild.txt. Or
maybe I missed something?

-- Ahmed Bougacha

Tom, Krzysztof, Ahmed, thank you!

Updating the configure.ac script in projects/sample/autoconf and running ./autoconf/AutoRegen.sh have fixed my trouble. In error, I updated autoconf/configure.ac instead projects/sample/autoconf/configure.ac. What difference between these scripts?

2013/2/1 Ahmed Bougacha <ahmed.bougacha@gmail.com>