Cygwin binaries

I'm building on cygwin. But the procedure for building the front-end on
Cygwin is a bit daunting, to say the least,.

Does anyone know a source for a pre-built version of the same?

From: "Robin Davies" <rerdavies@rogers.com>

I'm building on cygwin. But the procedure for building the front-end on
Cygwin is a bit daunting, to say the least,.

Does anyone know a source for a pre-built version of the same?

To my knowledge there is no pre-built version of the cfe. However, if you like I can give you the build instructions. It isn't that daunting to build it, if you've the right setup :wink:

Henrik

Does anyone know a source for a pre-built version of the same?

To my knowledge there is no pre-built version of the cfe.

See following link for CFE :-

        http://illuvium.com/download/

It maybe a bit out of date.

I believe the CFE maybe broken at the moment, at least the Cygwin nightly test reports that it is broken and I believe this is the same thing ?

        http://illuvium.com/testresults/Cygwin/

However, if you like I can give you the build instructions. It isn't that daunting to build it, if you've the right setup :wink:

I would be very interested in proper build instructions for the CFE as I have tried it twice, and failed. I built GCC 3.4.3 under cygwin and used the correct version of binutils...but failed.

Aaron

Hi Aaron,

Sorry for the delay. Please be aware, that these instructions has not been used lately. However, I'll try to follow up on your questions.

Here are my instructions to compile the cfe:

5. Configure, build, and install the C front-end:
a. Before configure: export CPPFLAGS="-D__MINGW32__ "
                                 ?export LDFLAGS=-Wl,-no-keep-memory"
                                   export CFEINSTALL=/C/LLVM/cfe

cd objdir
make distclean

If objdir != srcdir: Change all absolute paths given to source directory
relative by using --srcdir option for configure:

configure --prefix=$CFEINSTALL --disable-threads --disable-nls --disable-shared --enable-languages=c,c++ --program-prefix=llvm- --srcdir=../../../src/llvm-gcc-1/llvm-gcc --includedir=/C/MinGW mingw32

make CFLAGS=-O LIBCFLAGS+=-g LIBCFLAGS+=-O2 LIBCXXFLAGS+=-g LIBCXXFLAGS+=-O2 LIBCXXFLAGS+=-fno-implicit-templates all

On error:

Sorry for the delay. Please be aware, that these instructions has not been used lately. However, I'll try to follow up on your questions.

Thanks for getting back to me. Unfortunately I lost my Cygwin configuration and cannot even seem to get GCC 3.4.3 built on CygWin now, when I had it built before. Been trying all day to get it to work maybe I will crack it tomorrow as I have had enough for today.

Here are my instructions to compile the cfe:
[snip]

Wow, thats quite some set of fixes to preform, looks like it is pritty "broken".

Okay, hopefully I get GCC 3.4.3 built properly again tommorrow and can try it.

Many thanks,

Aaron

Hi Aaron,

Please be aware that my instructions are directed to get the cfe to compile on mingw. I wasn't in the first place aware that you were building on the Cygwin platform.

However, me and others will try to help you to compile the cfe. Please submit your compiling errors on this mailing list.

Henrik.

Hello, Henrik.

You wrote Friday, May 13, 2005, 5:52:11 PM:

However, me and others will try to help you to compile the cfe. Please
submit your compiling errors on this mailing list.

I've compiled CFE on cygwin this winter without any problems. I really
didn't change anything to let it work.

Hi,

I have got GCC 3.4.3 and binutils 2.15 installed on Cygwin.

Had to copy as.exe to gccas.exe to get llvm-gcc to get this far.

I am getting the following error message(s) :-

/usr/build/llvm-gcc/gcc/xgcc -B/usr/build/llvm-gcc/gcc/ -B/usr/llvm-gcc/i686-pc-
cygwin/bin/ -B/usr/llvm-gcc/i686-pc-cygwin/lib/ -isystem /usr/llvm-gcc/i686-pc-c
ygwin/include -isystem /usr/llvm-gcc/i686-pc-cygwin/sys-include -O2 -I../../../s
rc/llvm-gcc/gcc/../winsup/w32api/include -I../../../src/llvm-gcc/gcc/../winsup/i
nclude -I../../../src/llvm-gcc/gcc/../winsup/cygwin/include -DIN_GCC -DDEFAULT_
TARGET_MACHINE=\"i686-pc-cygwin\" -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -isystem ./include -g -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NE
EDED -I. -I. -I../../../src/llvm-gcc/gcc -I../../../src/llvm-gcc/gcc/. -I../../
../src/llvm-gcc/gcc/../include -DL_muldi3 -c ../../../src/llvm-gcc/gcc/libgcc2
.c -o libgcc/./_muldi3.o
/tmp/cctoZeMj.s: Assembler messages:
/tmp/cctoZeMj.s:1: Error: no such instruction: `gnu C version 3.4-llvm 20030924
(experimental)(i686-pc-cygwin)'
/tmp/cctoZeMj.s:2: Error: no such instruction: `compiled by GNU C version 3.4.3.
'
/tmp/cctoZeMj.s:3: Error: no such instruction: `ggc heuristics:--param ggc-min-e
xpand=30 --param ggc-min-heapsize=4096'
/tmp/cctoZeMj.s:4: Error: no such instruction: `options passed:-I../../../src/ll
vm-gcc/gcc/../winsup/w32api/include'
/tmp/cctoZeMj.s:5: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:6: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:7: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:8: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:9: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:10: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:11: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:12: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:13: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:14: Error: no such instruction: `options enabled:-feliminate-unu
sed-debug-types -fdefer-pop'
/tmp/cctoZeMj.s:15: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:16: Error: junk at end of line, first unrecognized character is

< ----------------------------- snip ---------------------------->

/tmp/cc4867fH.s:668: Error: bad expression
/tmp/cc4867fH.s:668: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:669: Error: no such instruction: `store {}* %dbg.tmp.15,{}** %db
g.0'
/tmp/cc4867fH.s:670: Error: no such instruction: `br label %return'
/tmp/cc4867fH.s:672: Error: junk at end of line, first unrecognized character is
`%'
/tmp/cc4867fH.s:672: Error: bad expression
/tmp/cc4867fH.s:672: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:673: Error: junk at end of line, first unrecognized character is
`%'
/tmp/cc4867fH.s:673: Error: bad expression
/tmp/cc4867fH.s:673: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:674: Error: no such instruction: `store {}* %dbg.tmp.17,{}** %db
g.0'
/tmp/cc4867fH.s:675: Error: junk at end of line, first unrecognized character is
`%'
/tmp/cc4867fH.s:676: Error: suffix or operands invalid for `ret'
/tmp/cc4867fH.s:677: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:679: Error: no such instruction: `created by "GCC: (GNU) 3.4-llv
m 20030924 (experimental)"'
make[2]: *** [libgcc/./_muldi3.o] Error 1
make[2]: Leaving directory `/usr/build/llvm-gcc/gcc'
make[1]: *** [libgcc.a] Error 2
make[1]: Leaving directory `/usr/build/llvm-gcc/gcc'
make: *** [all-gcc] Error 2

The temporary file gets deleted otherwise I would attach it.

Hope you can help,

Aaron

I have got GCC 3.4.3 and binutils 2.15 installed on Cygwin.

Had to copy as.exe to gccas.exe to get llvm-gcc to get this far.

This is the problem. Don't do that :). llvm-gcc produces .ll files which are 'assembled' by gccas. These files won't be understood by the system assembler. If you download the LLVM distro and build it, it should build a gccas.exe file for you.

-Chris

I am getting the following error message(s) :-

/usr/build/llvm-gcc/gcc/xgcc -B/usr/build/llvm-gcc/gcc/ -B/usr/llvm-gcc/i686-pc-
cygwin/bin/ -B/usr/llvm-gcc/i686-pc-cygwin/lib/ -isystem /usr/llvm-gcc/i686-pc-c
ygwin/include -isystem /usr/llvm-gcc/i686-pc-cygwin/sys-include -O2 -I../../../s
rc/llvm-gcc/gcc/../winsup/w32api/include -I../../../src/llvm-gcc/gcc/../winsup/i
nclude -I../../../src/llvm-gcc/gcc/../winsup/cygwin/include -DIN_GCC -DDEFAULT_
TARGET_MACHINE=\"i686-pc-cygwin\" -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -isystem ./include -g -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NE
EDED -I. -I. -I../../../src/llvm-gcc/gcc -I../../../src/llvm-gcc/gcc/. -I../../
../src/llvm-gcc/gcc/../include -DL_muldi3 -c ../../../src/llvm-gcc/gcc/libgcc2
.c -o libgcc/./_muldi3.o
/tmp/cctoZeMj.s: Assembler messages:
/tmp/cctoZeMj.s:1: Error: no such instruction: `gnu C version 3.4-llvm 20030924
(experimental)(i686-pc-cygwin)'
/tmp/cctoZeMj.s:2: Error: no such instruction: `compiled by GNU C version 3.4.3.
'
/tmp/cctoZeMj.s:3: Error: no such instruction: `ggc heuristics:--param ggc-min-e
xpand=30 --param ggc-min-heapsize=4096'
/tmp/cctoZeMj.s:4: Error: no such instruction: `options passed:-I../../../src/ll
vm-gcc/gcc/../winsup/w32api/include'
/tmp/cctoZeMj.s:5: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:6: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:7: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:8: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:9: Error: junk at end of line, first unrecognized character is `
-'
/tmp/cctoZeMj.s:10: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:11: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:12: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:13: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:14: Error: no such instruction: `options enabled:-feliminate-unu
sed-debug-types -fdefer-pop'
/tmp/cctoZeMj.s:15: Error: junk at end of line, first unrecognized character is
`-'
/tmp/cctoZeMj.s:16: Error: junk at end of line, first unrecognized character is

< ----------------------------- snip ---------------------------->

/tmp/cc4867fH.s:668: Error: bad expression
/tmp/cc4867fH.s:668: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:669: Error: no such instruction: `store {}* %dbg.tmp.15,{}** %db
g.0'
/tmp/cc4867fH.s:670: Error: no such instruction: `br label %return'
/tmp/cc4867fH.s:672: Error: junk at end of line, first unrecognized character is
`%'
/tmp/cc4867fH.s:672: Error: bad expression
/tmp/cc4867fH.s:672: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:673: Error: junk at end of line, first unrecognized character is
`%'
/tmp/cc4867fH.s:673: Error: bad expression
/tmp/cc4867fH.s:673: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:674: Error: no such instruction: `store {}* %dbg.tmp.17,{}** %db
g.0'
/tmp/cc4867fH.s:675: Error: junk at end of line, first unrecognized character is
`%'
/tmp/cc4867fH.s:676: Error: suffix or operands invalid for `ret'
/tmp/cc4867fH.s:677: Error: junk at end of line, first unrecognized character is
`}'
/tmp/cc4867fH.s:679: Error: no such instruction: `created by "GCC: (GNU) 3.4-llv
m 20030924 (experimental)"'
make[2]: *** [libgcc/./_muldi3.o] Error 1
make[2]: Leaving directory `/usr/build/llvm-gcc/gcc'
make[1]: *** [libgcc.a] Error 2
make[1]: Leaving directory `/usr/build/llvm-gcc/gcc'
make: *** [all-gcc] Error 2

The temporary file gets deleted otherwise I would attach it.

Hope you can help,

Aaron

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

Had to copy as.exe to gccas.exe to get llvm-gcc to get this far.

Woopse, just realized what I have done.

Sorry please ignore me.

Aaron