[Cygwin] Cygwin is broken again

llvm[2]: Linking Debug Loadable Module libCompilerDriver.dll
/usr/lib/gcc/i686-pc-cygwin/3.4.4/…/…/…/…/i686-pc-cygwin/bin/ld: unrecognized option ‘–enable-runtime-pseudo-relocs’
/usr/lib/gcc/i686-pc-cygwin/3.4.4/…/…/…/…/i686-pc-cygwin/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make[2]: *** [/home/ang/build/llvm/Debug/lib/libCompilerDriver.dll] Error 1

Cygwin is broken twice now. I reported this on the commits list and submitted a patch, but no one has checked it out as of yet.

Aaron

FWIW, I applied your patch for the OTHER Cygwin failure yesterday, so that one should be fixed.

--Owen

Owen,

Great thanks, the patch was okay then.

This latest break looks like its probably a binutils version problem, a newer feature being used '--enable-runtime-pseudo-relocs' for 'libCompilerDriver.dll'. Cygwin uses ld 2.18.50.20080625, this is the latest availiable for Cygwin.

Aaron

Hi Aaron,

Aaron Gray <aaronngray.lists <at> googlemail.com> writes:

unrecognized option '--enable-runtime-pseudo-relocs'

Interesting.
Does libCompilerDriver.dll link w/o '--enable-runtime-pseudo-relocs'?

If I understand correctly, this bug makes it impossible to produce loadable
modules on Cygwin.

Hi Aaron,

Aaron Gray <aaronngray.lists <at> googlemail.com> writes:

unrecognized option '--enable-runtime-pseudo-relocs'

Interesting.
Does libCompilerDriver.dll link w/o '--enable-runtime-pseudo-relocs'?

I have not tried as of yet.

If I understand correctly, this bug makes it impossible to produce loadable
modules on Cygwin.

I don't think Cygwin supports loadable modules anyway.

How do I disable this just on Cygwin ?

Aaron

Hi Aaron,

Aaron Gray <aaronngray.lists <at> googlemail.com> writes:

I have not tried as of yet.

Just compile with `make VERBOSE=1` and then copy, paste & edit
the offending line.

I don't think Cygwin supports loadable modules anyway.

Really, Cygwin doesn't allow to produce DLLs? Then I guess I
should make this a configure option.

Hi Mikhail,

Aaron Gray <aaronngray.lists <at> googlemail.com> writes:

I have not tried as of yet.

Just compile with `make VERBOSE=1` and then copy, paste & edit
the offending line.

Okay

I don't think Cygwin supports loadable modules anyway.

Really, Cygwin doesn't allow to produce DLLs? Then I guess I
should make this a configure option.

I sent you a _patch_ that disables it on Cygwin for the time being. LLVM does not load DLL's properly apparently. I would love to get to the bottom of this at some point.

Anyway the patch is on the commits list anyway.

Aaron

Hi Aaron,

Aaron Gray <aaronngray.lists <at> googlemail.com> writes:

I sent you a _patch_ that disables it on Cygwin for the time being. LLVM
does not load DLL's properly apparently. I would love to get to the bottom
of this at some point.

I've just added an --enable-llvmc-dynamic configure option (enabled
only on Windows by default). This is based on your patch.

Mikhail,

Great. Thanks alot,

Aaron

2009/7/3 Mikhail Glushenkov <foldr@codedgers.com>