doco build issue (how to skip question)

from a llvm and clang CO, I am consistently getting a build failure down in the build of Ocaml doco

lvm[1]: Building ocamldoc documentation
make[2]: Entering directory
   `/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml'
make[3]: Entering directory
   `/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml/llvm'
llvm[3]: Documenting llvm.odoc
make[3]: I: Command not found
make[3]:
   [/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml/llvm/Debug/llvm.odoc] Error 127 (ignored)
make[3]: Leaving directory `/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml/llvm'

Under the time honored principle of solving doco building problems last, I thought: Hmmm --- add a ./configure option and skip this for the moment

But running ./configure --help, nothing jumps out an bites me as a proper 'disable' clause to use. ditto reading README.txt and INSTALL.txt. I see the mention of missing -I paths in NOTES.txt, but this seems unlikely, except for the strange missing 'I' Command, rather than '-I' error

CentOS 5, currently updated and a rich build environment platform, on a x86_64

My build passes are laborious (working towoard auto-packagin the SRPM and binary RPMs) -- running over an hour, and so I'd appreciate a pointer.

Any thought?

-- Russ herrold

from a llvm and clang CO, I am consistently getting a
build failure down in the build of Ocaml doco

lvm[1]: Building ocamldoc documentation
make[2]: Entering directory
  `/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml'
make[3]: Entering directory
  `/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml/llvm'
llvm[3]: Documenting llvm.odoc
make[3]: I: Command not found
make[3]:
  [/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml/llvm/Debug/llvm.odoc]
Error 127 (ignored)
make[3]: Leaving directory
`/home/herrold/rpmbuild/BUILD/clang-20091005/bindings/ocaml/llvm'

Under the time honored principle of solving doco building
problems last, I thought: Hmmm --- add a ./configure option
and skip this for the moment

Hi Russ,

It looks like the configure is detecting ocaml support and trying to build the bindings. Try configuring with --enable-bindings=none.

-Chris

It looks like the configure is detecting ocaml support and trying to build the bindings. Try configuring with --enable-bindings=none.

will do -- I had tried adding, per an off list suggestiion:

   --disable-bindings=ocaml

and that was not the incantation that worked ... configure was simply not happy with it.

sadly:

+ ./configure --prefix=/usr --libdir=/usr/lib64 \
         --enable-optimized --enable-debug-runtime --enable-doxygen \
         --disable-static --with-gnu-ld --disable-bindings=ocaml \
configure: error: invalid feature name: bindings=ocaml
error: Bad exit status from /var/tmp/rpm-tmp.46097 (%build)

Thanks

-Chris

-- Russ herrold