Does LLDB work on windows?

I had LLDB working without any effort on linux however I can’t seem to get it working on windows. On this page titled LLDB Status it says LLDB is working on Windows (i386). I’m unsure if this means win32 apps, release or OS. I executed the below using llvm 64bit binary then tried again after uninstalling llvm and using the win32 binary

LLDB can’t seem to find my source file location. Doing a quick search and looking in I tried using settings set target.source-map MYPATH but it didn’t seem to help. source list gives me nothing. I’m using llvm 6. Specifically this build

$ cat a.c
#include <stdio.h>
int main() {
return 0;
$ clang -g -m32 a.c
$ ./a.exe
$ lldb a.exe
(lldb) target create “a.exe”
Current executable set to ‘a.exe’ (i686).
b main
(lldb) b main
Breakpoint 1: no locations (pending).
WARNING: Unable to resolve breakpoint to any actual locations.
(lldb) r
Process 2908 launching
(lldb) Process 2908 launched: ‘C:\Users\LD\Desktop\test\a.exe’ (i686)
Process 2908 exited with status = 0 (0x00000000)
(lldb) exit
(lldb) exit

same problem here, did you get this clarified elsewhere?

Somehow if you use lldb extension on vscode breakpoints seem to work though.

We faced this when trying to provide a reprex for another bug (gdwarf-4 debugging on windows) we encountered on windows