Dynamically loaded passes under OS X


In the past, I haven’t been able to get dynamically loaded passes to work under OS X. When I follow the instructions in the LLVM documentation, everything works fine for Linux, but OS X has a different way of handling dynamic loading, and the files that the dynamic loader is trained to look for don’t exist. In the past, I’ve worked around this by just linking all my passes into opt, but this isn’t going to work for me anymore.

So how do I get dynamically loaded passes to work on the Mac? Chris, you probably know the answer to this since you’re a Mac user now.


Robert L. Bocchino Jr.

Ph.D. Student

University of Illinois, Urbana-Champaign

The answer lies in the lib/System/ltdl.c which is the dynamic loader
used by LLVM for cross platform dynamic loading. If there are paths or
files that we're not looking for on OS/X then that needs to be fixed.
Could you be a little more specific about what failures you are


When I tried this a while back, the .so file wasn’t being built on Mac OS X. Now it looks like it is. I got dynamic loading to work following the instructions in http://llvm.cs.uiuc.edu/docs/WritingAnLLVMPass.html. However, there was a typo in the instructions (it should say LOADABLE_MODULE = 1), and I fixed that and committed it. I also fixed the sample/lib/sample Makefile to conform to these instructions.

So problem solved, thanks.


Here's why I was questioning the change to sample/lib/sample Makefile:

make[4]: Entering directory
llvm[4]: Compiling sample.c for Debug build (PIC)
llvm[4]: Linking Debug Shared Library sample.so
llvm[4]: Linking Debug Object Library sample.o
/proj/install/lib/libstdc++.a: member /proj/install/lib/libstdc++.a
(allocator-inst.o) in archive is not an object
collect2: ld returned 1 exit status
make[4]: *** [/proj/llvm/build/projects/sample/Debug/lib/sample.la]
Error 1


I believe that prior to the change the Makefile wasn't building a dynamic library (even though the comment said it was). The way it is now works on Persephone (the Mac) at UIUC. Without saying LOADABLE_MODULE = 1 I got an error on Persephone similar to what you report here. Is the problem possibly that the Makefile needs to be different for the different platforms?